I3 config doesn't run keyboard layout commands

Hey! I’ve recently switched to EOS and I love it so far! :slight_smile:
I’ve tried to get my keyboard layout to load everytime I boot by putting these commands in my i3 config:

Keyboard layout

exec setxkbmap -layout us,il
exec setxkbmap -option ‘grp:alt_shift_toggle’

However, they don’t seem to run whenever I boot, and I always have to input them myself. Does anyone have an idea why it could happen?

hey welcome to your endeavour and thanks for using i3! :enos:

exec --no-startup-id setxkbmap -layout us,il -option grp:alt_shift_toggle

is not working too?

and to make sure… you added this in ~/.config/i3/config ?

Hey! I tried that too right now and pressed Mod+Shift+R but it still did not work.

Yes, I did put it there. :slight_smile:

but running the command manually do work?

Yes. It does.
Maybe I need to log out instead of reloading i3 to check if the change you said worked?

could be in case something is not working i would try that at least…
As I just checked and it is working with this for me:
exec --no-startup-id setxkbmap -layout us,de -option grp:win_space_toggle
but alt_shift_toggle is working the same…

Thank you. I’ll try to logout and see if it’ll work :slight_smile:

I’ll update later, when I’m available to do so. Thank you so much!

zou are welcome!
ups <( …
you are welcome :wink:

1 Like

and yea need logout back in to load the change… just tested…

Okay! I’ll try thanks :slight_smile:

1 Like

Hey there! I wanted to thank you. It finally works now. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.