I3 block bandwidth didn't work

Hello everyone, I hope you’re doing good.

So I just fresh install changing to i3wm from XFCE. And I have a problem here, the bandwidth meter didn’t work. It work few days ago, but suddenly it stop working. I tried visit the EOS i3wm github, copy and paste the code, but still not work.


from the information you provided it’s difficult to judge what could have happened.

I looked at the github code and I could recommend this:

  1. Try to change command in ~/.config/i3/i3blocks.conf under [bandwidth] to something like command=echo aaa. If you see printed aaa in your bar then the problem is with the script ~/.config/i3/scripts/bandwidth2. If not then you probably uninstalled some essential package when you switched from XFCE to i3.
  2. You can test in your terminal return value of ~/.config/i3/scripts/bandwidth2 with correct parameters -i *yourInterfaceName* (something like enp0s32f7 - you can list your interfaces with ip a command) -t 1 -u MB

You’re right, I mess the script. There’s this Kb variable on bandwidth2. It should Kb not kb

Now it’s work again, thanks for helping me.
Have a good day!


I’m facing the same problem I have also switched from Xfce to i3 and comand=echo aaa does not display any output. what can I do?

Then it might this don’t you think.

List which packages you have intalled for i3wm (pacman -Qs i3) and try to reinstall them (pacman -Syu package-name)
Also write here which packages you actually have installed.

in addition, all commands from i3-bar are terminal outputs :wink: so you can run the used commands in the terminal to see if they work too… used scripts are all under ~/.config/i3/scripts to have them hackable for the user.

1 Like