I3 bar shutdown menu / power menu emoji not rendering

Since yesterday, I am noticing the letter ‘y’ appear in place of Shutdown menu on i3 block status-bar.
Also if you click on the power menu some of the emojis are replaced by letters for logout and shutdown.
I am attaching the picture.

Thinking aloud, could this be a i3gaps to i3 transition issue (which happened yesterday) ?
or could it be because I installed Microsoft fonts ttf-ms-win10-auto.

I tried to trouble shoot this problem by installing many more fonts.


But none of this worked.

Should I go to i3blocks config file and update the emojis from font awesome ?

This is a script that can be found in ~/.config/i3/scripts/powermenu. It uses rofi to launch the menu.

Can you open the script and show us the contents? On my system, it looks something like this:

The configuration for the powermenu can be found in ~/.config/rofi/powermenu.rasi. Open the file and check which font you are using. You should see a block like this:

configuration {
    font:            "Noto Sans Regular 10";
    show-icons:      false;
    icon-theme:      "Qogir";
    scroll-method:   0;
    disable-history: false;
    sidebar-mode:    false;

Thanks for so much for responding
I am sharing the sceenshot as discussed. Its seems the fonts have changed everywhere including the ‘i3 config’ file. I am attaching both the config pictures.
Further, I couldn’t find the ‘configuration {font}’ block of code in ~/.config/rofi/powermenu.rasi
That block of code is missing from the config file

Is font awesome installed on your system?

pacman -Qi ttf-font-awesome

Also, what terminal and terminal font are you using?

Update: Here is a little test for you to try out. Go to https://www.nerdfonts.com/cheat-sheet ; search for “user”, and then copy this icon into your clipboard.

Once you’ve copied the icon, paste it into your terminal at the command line. What do you see?

No I don’t think its installed or I must have removed it while cleaning up the system.

So when I ran the pacman -Qi ttf-font-awesome in the terminal

It returned as package ’ ‘ttf-font-awesome’ was not found’

Also the test you mentioned I ran that and it returned a “square root symbol with x on top” exactly like the logout symbol in the picture above.

Hi, Just as update to my last reply.

Since my Qi flag returned empty I guessed am missing the awesome font package, so I ran sudo pacman -Syu ttf-font-awesome and in installed them. After a reboot my logout symbol is fixed but shutdown is still showing a y symbol.

I guess I am missing some morefonts I think, but I don’t know which fonts.

Did that also change your “Logout” icon? It looks like the ‘square root of x’ from the screenshot.

i will share my latest screenshot. hangon

1 Like

Interesting … your Logout icon has been revised (to a head figure, same as seen on mine) yet your Shutdown icon remains the ‘y’ exponent. You’ve succeeded in changing fonts, but perhaps not to one that contains all of the icons you prefer.

One solution as alluded to above would be to edit the associated config file and see which icons are available in fonts you have already installed and make a choice from there.

As noted above by @anthony93, that file may be found under /.config/i3/scripts/powermenu

This means your terminal font does not support the shutdown icon.

Updated the config files ~/.config/i3/scripts/powermenu and ~/.config/i3/i3blocks.conf and added the font directly into the script. But for some reason some of the power menu in Font Awesome Free's cheatsheet doesn’t render properly and outputs as a raised to the power of y symbol.

Not not a big issue, as some similar looking fonts do render.
So I used record-vinyl font here which looks very similar. Here is the final product.

Thanks for you help ! I really appreciate it.