I3 adding keyboard layout

First of all I am not sure if i am allowed to open a new thread on this issue so @BONK please merge it with my other thread if not appropriate.
question on keyboard
To add a keyboard layout - Hebrew - I added this to my config file
exec --no-startup-id setxkbmap -layout 'us,il' -variant altgr-intl,qwerty -option 'grp:alt_shift_toggle'
mod+R to refresh restart
But it does not work.

  1. how do I add different keyboard layouts?
  2. How do I change between them?
    Thank you

setxkbmap -layout 'us,il' -variant altgr-intl,qwerty -option 'grp:alt_shift_toggle'
from terminal gives any error?

Hi @joekamprad Thanks for replying.

Here’s the output:

$ setxkbmap -layout 'us,il' -variant altgr-intl,qwerty -option 'grp:alt_shift_toggle' 

Error loading new keyboard description

I have same problem, but for my native, Romanian Language…
Are you fixed this problem?

needs a working command that works manually from terminal to get working as part of the config to start on login… the other option is to set this systemwide:

@wisdomlight @andrei-1101

It seems to be a bug from i3wm:


Thank you

I removed altgr-intl and it worked

exec --no-startup-id setxkbmap -layout 'us,mn' -variant qwerty -option 'grp:alt_shift_toggle'

1 Like

welcome on the purple side :enos: