I think I made a mess while reinstalling EOS... would really appreciate some help

hey everyone :')
(disclaimer: I am… a certified noob)

I think I made a real mess while installing EOS and then trying to kind-of reinstall it… so I might need an advice of someone experienced. I’ll begin from the start

I have an asus x550ik laptop with a hard drive of around 950 GB. Originally, I just had Windows 10 on it. I decided to pick a distro for myself to switch to (which was Fedora originally but not anymore), but I decided to keep Windows 10 just in case I would ever need it for a task that my new system would not be able to fulfill (I know not all Windows functions are perfectly recreated). So… I tried to make a new partition for Fedora (I encrypted it too), everything went alright.

after using it for some time, I decided that I want to switch to EOS instead, but I wasn’t sure whether to keep Fedora or not, and my 950 GB space allowed be to consider keeping it, so I decided I’ll keep it for now. I installed EOS, and it went fine too, but during the installation, there was a known bug (which the devs are already working on) - disk encryption is only available on the “install alongside” option (someone advised to try a manual partition too but it was full of options that I felt really unsure about). I have cleared up some space in the storage and made it unallocated beforehand because that was a problem I faced while installing Fedora. That’s why “install alongside” didn’t work for me and I went with another option, without disk encryption.

after some time, I felt like I wanted to reinstall my EOS, partially because I felt like I already got it full of unneded software, partially because I do want disk encryption after all, partially because I wanted to try out a different desktop environment. So I booted the live USB and I chose “install alongside” (since, again, only that option has disk encryption). My plan was: install EOS 2 alongside, then erase the EOS 1 through GParted and just keep using EOS 2. So that’s exactly what I did - I erased EOS 1 through GParted while still being in the live USB system. The erased partition started showing as “unallocated space” in GParted. I booted into the second EOS, and generally everything was (and still is) alright, but I have 2 problems now:

  1. my boot loader menu for some reason still has the old EOS versions, so now each kernel has 2 versions of booting, one of which never works ( due to me having cleared it’s partition, obviously)
  2. as shown on the screenshot below, when I open my file manager, on the left, for some reason, I see 2 systems named “endeavouros” and both of them have the same size (even though I vividly remember shrinking the EOS 1 to around 40-50 GB before erasing it, and the new one should be around 430 GB, but they both are 430 GB)

this confuses me and I am unsure what to do.

I asked someone in the community what’s the proper way to uninstall a system and they said “through GParted”, but that’s exactly what I did and… here we are.

so… what I’m asking for is this:

  1. think I would like to be advised on how to PROPERLY erase all my current EOS, in such a way that they would not show up anywhere anymore, not in boot loader, not in file manager, etc.; only after that I wanna reinstall a clean EOS again, just to make sure to get rid of all the issues.
  2. I would also like to know which specific partitions of my hard drive I can erase (I only want to erase all EOS versions, not Fedora or Windows)
    to make it easier to tell which one is which, I would like to remind that only Windows and EOS 1 are non-encrypted, while Fedora and EOS 2 are encrypted (and again, EOS 1 was shrinked to around 40 or 50 GB and then erased through GParted)

I attached some captioned screenshots in hopes that they would make sense to someone experienced in this, because to me they sure make little sense :')
please let me know if any additional info is needed.
thanks a lot in advance to whoever is willing to try to help me out.


i saw some of this already :wink:

yeah, I just thought maybe someone on the forums knows a different way of fully uninstalling a system, so that it wouldn’t show up anywhere, because GParted didn’t do that for me… if not, then not :')

1 Like

this is fedora? encrypted?

… it probably is…?
only Fedora and EOS 2 are encrypted, so yeah I’m positive that should be Fedora

edit: I’m not sure about the /dev/sda5 though, I don’t even know what that is tbh

now that i see gparted output… it should be possible to add the empty space to the endeavouros system partition, not 100% sure …

well… for some reason, rightclicking on it in GParted only allows me the options “New” and “Information”; all the rest of the options are unavailable. And if I try to resize the current EOS, it doesn’t let me to either shrink or extend it at all

i am offline for today already…
äh its the next day already… but i need some rest :wink:

Hope someone else can join to your fixing party !

1 Like

Your partitioning seems corrupted. It (sudo fdisk -l) says,

Partition 9 does not start on physical sector boundary

There are ways to fix that, however, a backup of sensitive data is dearly recommended before proceeding at your own risk:

1 Like

sensitive data?
does that only mean my photos and other files and such, or something else? (I’m asking just in case there is anything from “under the hood” like some sort of system files that I need to backup and I don’t know about, although it shouldn’t matter if I want to do a clean install later anyway. I also hope none of this interacts and messes with other partitions and their data and files)

thanks a lot for the advice, although this doesn’t cover the part of how I can properly fully delete a system so that it wouldn’t show up anywhere at all, but still thanks, this is useful

Your sensitivity, your data, your decision what to back up before proceeding. In a worst case, you need to reinstall afterwards. Your awareness of ongoings under the hood? I wouldn’t worry about them in such a case. EnOS and Linux systems in general are self-sufficiently reinstalled easily. A bad partition however can have grave consequences for important data of yours in the future.

1 Like


This part is limited to what is possible from natural limitations on the hardware and software … and that’s the reason why everyone is recommending backup Data before doing any tasks like this.
Something can go wrong like a simple system freeze-up when a massive data transfer… power outage user doing user stuff :wink:
It is always the cleaner and safer way to backup personal data and do clean start when creating partitions.

I mean yeah… I already made a backup of my files on a separate USB drive
I just hope there are ways to fully remove the systems that I already have… and whether GParted is the only way to do so (because… last time I used it to remove a partition, well… here we are). But I guess I should at least try to search for the others ways first. Sorry about that, it was probably stupid of me to ask about it before doing a research first

I also wanted to know about every single partition on my hard drive, and which is which, because… besides things like Fedora, Windows and EOS partitions, I also have some kind of very small sized ones that I don’t know what they are and whether I should remove them as well or not… (I highlighted them on the screenshot here)

edit: the label of the first one says “Restore”

This was a success. Everything is OK!

We/you need to have a better picture of those.

  • Which boot loader menu do you mean? BIOS, or systemd-boot (EnOS boot menu)?

As said above, it is not obviously, unless we know which menu you mean.
If it is the BIOS menu, it would be the old EnOS entry, which you can delete it with efibootmgr
If it is systemd-boot menu, the entries would have different text. If so, which one fails?
If the text is the same, you may need to check your systemd-menu configuration for some extra/wrong configuration.

This is an issue with the specific File manager (which is…?), usually. IIRC, this happens when using encrypted partitions, or other LVMs. If so, you may hide one of those, if possible (IIRC dolphin can do it). You can also test (and post) what happens when you activate/click on each of them. If it has the same result, then, just ignore them, or hide one of them. If not, give more details.

I suggest you don’t do that. Just fix the above issues. Your system is how you want it. :person_shrugging:

Your old EnOS partition is erased properly. That’s what unallocated means (empty space) for both places (between sda4 and sda5, also sda7 and sda9). Check the sizes.

Part Owner Usage
sda1 WinOS hidden recovery/restore partition
sda2 system EFI partition initial/original. Used by WinOS and maybe other OSes
sda3 WinOS WinOS bootloader. Needed for WinOS
sda4 WinOS Main WinOS system and data
sda5 Fedora (probably) Probably /boot (ext4 partition)
sda6 Fedora Fedora encrypted main partition
sda7 EnOS EFI partition mounted on /efi (cool! :wink: )
sda9 EnOS EnOS encrypted main partition
unallocated empty Usable. You can create new partition(s) there.
1 Like

well… I think it’s the systemd-boot. It’s the one that shows up right after the asus logo, it looks like small white text at the center of a black screen.

my file mamager is Dolphin.
may I ask, how exactly is it possible to hide the unnecessary one in Dolphin? o:

I actually think I would prefer to do that - I would like a new, clean EOS install just to make sure that the red text error from my terminal screenshot (“Partition 9 does not start on physical sector boundary”) and any other issues that I might be unaware of would be resolved. I also like the idea of a clean install and I really don’t mind doing it once more, and besides, one of the mods (or admins? not sure) of the Telegram EOS channel confirmed to me that I can safely delete (using GParted) the distro partitions as well as their uEfi boot loaders, and has shown me which one are Windows-related, so I believe I’ll just remove everything non-Windows and do a clean install (that is what I want)

thanks a lot for clarifying my partitions! This is very useful :slight_smile:

Right-click on the partition name (left pane). From the context menu, select “Hide”.

Your system, your rules :person_shrugging:
Have fun! :smile:

1 Like

the one thing I forgot is…I would really like to use disk encryption, but the EOS installer only offers an encryption option if I select the “Install alongside” option, which is probably (?) unavailable for unallocated space, probably only available for existing partitions. So I don’t know what to do with that… although someone else in EOS Telegram offered to guide me through a manual partition to achieve encryption. I would love to stay out of that just due to feeling a lot safer about the automated options… but this might be the only way, haha.

well, anyway, again, thanks a lot for the help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.