I need help setting up ibus in sway

Greetings everyone!

So… here’s the problem, I installed EndeavourOS for a while now and I decided to go with swaywm (I’m not using community editions, I installed KDE first before switching over to sway) because I like neither GNOME nor KDE. After setting up the bar and everything, I decided to tackle input options (I’m Vietnamese) and for years I’ve always sticked with https://github.com/BambooEngine/ibus-bamboo

When I run ibus-daemon, I get this:

portal is not running: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.portal.IBus exited with status 1

I really have no idea why, things I’ve tried are:

  • Installing xdg-desktop-portal (I recalled there’s a package like this and since it says “portal”, I figured it might help)

  • Installing the lastest ibus-git package from AUR

  • Messed around with some environment variables such as: XDG_SESSION_TYPE, XDG_CURRENT_DESKTOP

Information on the internet is very limited, I can’t seem to find someone with the same problem as mine. Theirs just work out of the box, so I don’t think a bug report would make sense. I’ve confirmed wayland works. I’ve used it before in KDE Wayland. Running ibus-daemon -drx gives no error though (I’m not sure what it does, found it while researching haha uhhhhhh)

Thanks in advance :wink:

Hi and welcome to EnOS’ community @toara!

Did you try:


in /etc/environment ?

:eye: https://wiki.archlinux.org/title/IBus

Welcome to the forum @toara :enos: :enos_flag: :tada:

Hello thanks everyone for the warming welcome <3

It worked! Thank you so much, I found out that while the tray icon isn’t showing, ibus-daemon was indeed running in the background, I can type Vietnamese now. I didn’t notice this because I couldn’t see the tray icon so I just hastily concluded that ibus wasn’t running, silly me :stuck_out_tongue:

But there’s one problem, and a big one at that… Without the tray icon, I cannot configure ibus-bamboo, well as far as I know there’s no way apart from right clicking the tray icon to get the option menu to show up. The waybar tray icon is working well, at least for the discord tray icon. It’s true that waybar tray icon is unfinished, maybe it’s waybar’s fault? In any case I’m making a bug report.

Thanks everyone!

1 Like