I need help mounting my drive


My /etc/fstab folder file (semantics) is completely empty, The USB sata drive dock culprit is unmounted. There are two existing drive mount topics on Endeavor forums and a couple linuxhint.com threads, but the Endeavour ones seem server related (Which turn out less helpful to me), the posters seemed familiar with creating mounting points. Contrarily I really just absolutely do not know what I am doing. I don’t quite think that I have gotten the terminal to name the unmounted USB drive for me with fdisk --list. Administrator privileges do not make that command work either. I have a feeling the drive name isn’t sdb ( :white_check_mark:sbd is the dock name :white_check_mark:, Drive name is still unknown and isn’t detected.) and isn’t showing up via lsblk, could be wrong. Not that the following matters much, but my EndeavourOS image partition may have been set up with an dummy partition for older device compatibility, so that may or may not account for what does show up being sdb. Copying my data from this drive is important to me and I would really like to do that soon. I seem to remember drive mounting also being an absolute pain from my time spent with Ubuntu 14.

This is not a folder it’s a file. Try cat /etc/fstab. You’ll be able to see the content of the file. But you won’t see your USB in there because it’s not a permanent mount. fstab is used for permanently mounting drives or partitions (USB or any other).

Don’t know which one you are talking about but I might have been the author of one. And no it’s not related to servers (enos doesn’t have such an edition. But you can use the distro like a server edition with tweaks). Those posts contain the normal way we can perma mount an external or an internal drive, Mount points always are created for any mounting of a drive type in Linux.

This is evident from your screen shot :slight_smile: .

According to your screen grab you’re trying to run it as fdisk --list don’t how you gave it root or admin access. But if your run it as sudo fdisk --list it should give the below output.

To list all your drives you can run lsblk -l which should show something like below.

In order to further help you please run this command in your terminal inxi -Fxxc0z --no-host | eos-sendlog and post the link it shows here.

https://clbin.com/80pwl

Drives:    Local Storage: total: 465.76 GiB used: 19.84 GiB (4.3%)
           ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
           speed: 6.0 Gb/s serial: <filter>

Well, it seems the system is only showing your internal drive is your external USB drive plugged in or not?

Yes it is. Power LED is on too. Plugged into motherboard back IO.

Seems the dock is not getting picked up by the system because if it did it should show something like this.

 ID-4: /dev/sdb type: USB vendor: SMI (STMicroelectronics) model: USB DISK
           size: 7.47 GiB serial: <filter>

Did you do restart after plugging in your dock? if not could you shut down the system and start it again. Do not do a Reboot. And the run lsblk -l in the terminal.

Yea I have just full-system shutdown and ran lsblk -l

NAME                                      MAJ:MIN  RM  SIZE    RO TYPE  MOUNTPOINTS
sda                                         8:0    0   465.8G  0        disk  
sda1                                        8:1    0   465.8G  0        part  
sdb                                         8:16   0       0B  0        disk  
luks-57cc5dcc-d7a2-471d-b204-18e814fee647 254:0    0   465.8G  0  crypt /

Whats odd though is that both before system shutdown, and after, the drive persists to keep showing under computer:///. But isn’t detected by commands. Or at least I think it’s not sdb. If it is then like problem would be like half-way solved

Seems sdb is the dock but it not picking up your drive. I’m going to tag some one with better brain power than me :stuck_out_tongue: .

@dalto and @ricklinux Can one of you help us, please.

1 Like

Ok so development has happened, The drive was shook from the external docks’ sata port a bit and needed encouragement :P. so that is now fixed and now the drive is plugged in.

1 Like

:rofl: see. This is why I say computer are like women they need some tender love to work.

Anyway, can you see the drive now? and access it?

Uhhhhh no infact having the sata drive actually plugged in has made the dock dissapear from lsblk -l and computer:/// after hard-power-off computer and on again.

$ lsblk -l
NAME                                      MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
sda                                         8:0    0 465.8G  0 disk  
sda1                                        8:1    0 465.8G  0 part  
luks-57cc5dcc-d7a2-471d-b204-18e814fee647 254:0    0 465.8G  0 crypt /

:disappointed:

Assuming the drive does show up, what then?

If it shows up you only have to click on the icon in thunar file manager it will automount. Then you can unmount it when you’re done. But don’t force pull it out wait till the message disappears because the files you copied are getting transferred from your computer’s temp mount point to your drive.

1 Like

Hey sandman!
This is a newbie suggestion as we’re both on the same boat of “don’t know what I’m doing” :laughing: so hopefully I am helping you, but if not I apologize.

If you are using KDE environment, you can Start and type “removable devices”. There you can check the options of automount removable drives when you plug them in.

You could also ctrl+alt+T to open the terminal and type:

sudo pacman -S gnome-disk-utility and see if it’s recognized.

You should try, if possible, to use another USB port as well. Preferably one that you know it works well.
That’s all I think of and hopefully understood your issue correctly. Hope you can solve it!

2 Likes

External Drive seems to have automatically mounted when I tried a different USB 3 port directly next to the other port on the motherboard :man_shrugging:. Thx for all of the troubleshooting steps though :+1:!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.