I messed up Libreoffice

Hello all.

Yesterday I was trying to add CoolProp to Libreoffice Calc as described here http://www.coolprop.org/coolprop/wrappers/LibreOffice/index.html
This is specialized package and while trying to get it installed as an add on, I made a mistake. I tried to add the zip file straight to the add on manager.
Now, Libreoffice does work, but performance has taken a huge hit. Now when I start it, it takes up to minute to start, and the fans in my laptop go to full blast.
The zip seems to be “stuck” in the add on manager, and when I try to delete it, it shows me this prompt (sorry for the pick, but I can’t copy the text)

Basically, it can’t find this package because the directory doesn’t exist.

Now, could someone please help figuring out the cause of the issue, and hopefully help fixing my mistake.

With much hope
Ólafur Víðir (Oli for short)

I’m rather pragmatic, and would reinstall LibreOffice rather than spending hours trying to fix it, but…

Did you install CoolProp acording to their page, or did you install the AUR version?


I have tried uninstalling libreoffice and installing it again, and the problem persist

I tried to install CoolProp as mentioned on their page, but was unsuccessful (I did not find the oxt file at all in their package), ended using pip3 as seen at the end of the tutorial. Still can’t really use this extension in libreoffice.

I did not know of the aur package

Find every instance of libreoffice (except icons) and remove them, then reinstall. Either use locate, find or fd.


Sounds promising, is that
sudo rm libreoffice* or something similar to that?

(I am looking through Arch wiki as we speak)


pacman -Rsc package_name sounds correct

Install mlocate, run sudo updatedb, then run:

locate libreoffice

This will give you a list of files - remove them


Install fd:

fd libreoffice /

To get a list.

As I said - ignore icons/png/jpegs.

I have stupid many files under


Can I delete them too?

You can leave them.

Ok, have deleted everything else from libreoffice. Will try to reinstall now.

This did the trick… thank you for the help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.