I installed EndeavorOS alongside Linux Mint and now my laptop does not boot into EndeavorOS

I had installed Linux Mint on my laptop. Then I came across Endeavor OS so I decided to give it a try.
I booted into the live Endeavor OS session and used GParted to create an empty ext4 partition for the / of endeavor OS. Then I started the Calameres installer.

Everything went fine until the disk space allotment stage. There I chose “Install alongside” and just selected the empty partition I had created using GParted. That is it. I did not create a /boot/efi partition.

My Linux Mint OS boots from /boot partition that is formatted to FAT32 fs. I know that endeavor OS needs a /boot/efi partition to begin booting but I didn’t create a separate partition for that as I thought Endeavour OS would automatically detect the boot partition and include an entry for itself alongside the Linux Mint OS’s entry.

As I didn’t create a /boot/efi parition. I should have gotten an error but I didn’t. Now when I switch on my laptop, I boot directly into Linux Mint. I know for sure that Endeavor OS is still there on the partition I installed it on. Is there a way to get a grub listing for both the OSes I have installed on my laptop SSD?

Thanks in advance for help.

Welcome @HumptyD
Other distros fail to create the grub entries properly for Arch based systems. Are you able to show


BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,2001,3004,0001,2002,2004
Boot0001* endeavouros
Boot0004* ubuntu
Boot0005* USB Hard Drive (UEFI) - SanDisk (SanDisk)
Boot0006* Fedora
Boot0007* USB Hard Drive (UEFI) - SanDisk (SanDisk)
Boot000A* USB Hard Drive (UEFI) - SanDisk (SanDisk)
Boot2001* EFI USB Device
Boot3004* Internal Hard Disk or Solid State Disk

You can try changing the boot order to boot into EndeavourOS first. Then maybe you can fix it from there if you are able to boot into it.

sudo efibootmgr -o 0001,0004,2001,3004,2004

If it boots into endeavouros after then you need to check if os-prober is set properly in the default grub command line and then update grub.

This unfortunately doesn’t work. The laptop automatically boots into Linux MInt. And the boot order remains unchanged when I check using efibootmgr
Is there another way?

See if you can change the boot order in firmware/bios settings.


Yes as @pebcak say’s see if you can change the boot order to boot Endeavour or not in bios.

1 Like

Grub …is not my forte! :grin:

1 Like

Not certain about endeavour but i know mint grub cant boot manjaro but manjaro can boot mint. If its the same on endeavour then what id do is use an endeavour live usb to boot and then chroot to install/update grub.

Apologies if its different on endeavour

I would say we need to know exactly what is where on the drives. It sounds to me like Mint is booting MBR rather than UEFI - with all the confusion that adds in! Deciding which fix makes the most sense is only possible when we have the correct layout.

ZIt would also be nice to know how much ‘stuff’ is present in each distro - has Mint been there long, and is much setup on it? Same question for the EnOS install - can EnOS be re-installed without losing much? They both could, perhaps, be setup for MBR booting - but preferable would be to change to UEFI for the future… (if that is the current state of things). Interesting that the UEFI refers to Ubuntu, rather than Mint - from an earlier install before Mint was chosen?

Thoughts for now…

I’d suggest that rather than trying to fix an EnOS installation that has never worked that you go back through the installation process and make sure a bootloader is installed.