I have no internet connection while on the live session, so I can not install Endeavour OS

Hi, I have been trying to install Endeavour OS on my computer (R7 3700x, 2080s, Asus B450i) but I am stuck on the live session as it does not recognize the ethernet port (or the wifi) of my motherboard and that prevents the installer to launch.

I ran a sum check on the ISO I downloaded and also tried it first on a VM, where it worked fine. I also
tried to create the bootable usb following the guide on the official website as well as using an alternative software. I tried both the default live session as well as the one with proprietary drivers, same result…

I ran out of ideas, that’s why I need your help with this issue. Thank you all in advance.


(The output of running ‘systemctl status NetworkManager’)

Hello @avgdd
Could you boot on the live ISO and post the output link to

inxi -Faz --no-host | eos-sendlog

Edit: Are you using the latest ISO?

1 Like

Welcome to the forum! :smile:

Can you use your phone with USB tethering? If so, then you can send the log.

Note that there’s an offline install mode which does not require a connection. It provides a nice Xfce desktop.

Hi, I just ran the code and it gets stuck, no response from the terminal. I am using the latest iso, yeah.

I tried to use an older iso and it worked just fine, but I would like to use the most recent one

If the older one works then use it as there will be no difference really. Otherwise you could use a mobile phone with USB tethering or install the offline version of Xfce is another option. Honestly if the other ISO works then I would use it.

Thats odd, is the iso running with newest kernel and not lts? That means it may be wise to stick with lts and check what happened in the kernel with your driver support.

If you install using the old iso I would also tick lts kernel to be sure.

I installed the old iso since I just wanted to try the os. But still, I would prefer to use the new installer once I completely migrate since some of the options there are useful for me

Also, usb thetering didn’t work. I could not open some of the apps in the live session either (like firefox). It felt like something was off

I installed through the old ISO and now I am running the latest kernel with no problem. I guess some bad driver got into the latest iso preventing my pc to work fine

Can you provide the link to this hardware command.

inxi -Faz --no-host | eos-sendlog

I can not, the console gets stuck and nothing happens. Crtl c does not work either, I hace to kill the terminal from the window…

How did you install then? It’s working or not?

Edit: You just open the terminal and enter

inxi -Faz --no-host | eos-sendlog

It will give you a link to the uploaded file for the hardware

I did install the iso from April, which works fine
The iso from August (latest) does not allow me to execute that command.

I can send you the link from using that command on the installation of the old iso, which is the one working.

Let me power on the Pc and run it

If the computer is working and installed i just wanted you to put the command in the terminal and provide me the link so i can see what the hardware shows after you got it installed.

@avgdd you not having internet is very strange, your board has intel nics which are supported OOTB by the kernel

We have had a couple of users with similar issue with the Intel on Asus ROG Boards. I’m sure his has the same components.

Edit: What i don’t know is why?

Wonder what Asus is doing with it? I have a Gigabyte board with Intel Nics and no issues (x470 so should be same NICs or close)

@avgdd can you run

lspci -vvv

in a terminal and post the output? I want to see exactly what NICs you have. The Wifi might be listed with


lsusb

Ya I’ve been waiting for some hardware info also to check if it’s the same.

I can confirm the Ethernet NIC is Intel® I211-AT

Asus doesnt list the wifi,
EDIT: Thanks Asus, super descriptive

Screenshot from 2021-09-18 16-46-56

There actually is a BIOS update specifically for the board that was for linux problems but idk what bios revision theyre on