I have an issue with KDE's SDDM and i3lock-fancy's xidlehook


Since the latest update of Arch repo, the pam broke the system and I removed the file .pam_environment. I had to make clean reinstall.

Observe that SDDM and i3lock-fancy’s xidlehook work perfectly. It used to suspend perfectly before the latest update. Now after the latest update, the problem is the SDDM which overwrote the xidlehook, did not suspend, but logged the session out instead of xidlehook.

I want to keep SDDM as the default login screen, but i3lock-fancy’s xidlehook as default lock screen and suspend.

After the suspend, the PC enters into xidlehook, and after a little inactivity, it enters into SDDM instead of xidlehook. I notice it did not suspend. When I wake up the computer and log in SDDM, all the apps were or the session was gone. It seems that SDDM did not suspend but logs out, it overwrites the xidlehook.


$ i3 --version
i3 version 4.18.2 (2020-07-26)
$ xidlehook --version
xidlehook 0.9.1

The old ghost problem is returning with the new video card AMD RX 5700XT.

$ i3 -v
i3 version 4.18.2-10-g07d82753 (, branch "gaps-kde") © 2009 Michael Stapelberg and contributors
$ xidlehook --version
xidlehook 0.9.1

The ghost problem of session restoration and logoff has been solved with:

  • I had to purge totally SDDM;
  • I had to type my username, my password from tty and to run startx
  • I found the ghost and dead NVIDIA services, and removed them;
  • I copied the services from @dbrgn’s his dotfiles to /etc/systemd/system/ and modified the xidlehook.service , and enabled and started the services;
  • I created the ssh-agent in the user systemd, enabled and started it.

It worked only on i3, but it does not work on Sway.

Sway uses Wayland rather than X, so that’s probably to be expected.

1 Like

Then therefore, I will create the condition for detecting the desktop sessions and switching to export QT_QPA_PLATFORM that I’m speaking about in another topic.