I cant update

hi, I tried to update, (I used yay), and I got this installation thing about a keystring, and then this happened.

please help!!!

Make sure your keyrings are updated, you can do so with this command

sudo pacman -Sy archlinux-keyring

Then try to update with yay again.

or use eos-update it will do some checks and will update keyring before the rest if needed…


i tried both, and this is what happened:


Build up your pacman keys from scratch:

1 Like

it wont work…


Please don’t post screenshots of terminal output.

Copy the terminal output as text, paste it into your reply, highlight it and press Ctrl-E to format.

1 Like


[leonorat@leonora-20aws0du00 ~]$ sudo pacman -Sy archlinux-keyring endeavouros-keyring sudo pacman -Syu
[sudo] password for leonorat: 
error: only one operation may be used at a time
[leonorat@leonora-20aws0du00 ~]$  /var/cache/pacman/pkg/
bash: /var/cache/pacman/pkg/: Is a directory
  1. sudo mv /etc/pacman.d/gnupg /root/pacman-key.bak
  2. sudo pacman-key --init
  3. sudo pacman-key --populate archlinux endeavouros
  4. sudo pacman -Syy archlinux-keyring endeavouros-keyring
  5. sudo pacman -Syyu

One command at a time.


omg, THANK YOU!!!

1 Like
eos-update --keyrings-reset

does the same.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.