I can't start steam after fresh install

core 2 quad Q8200
GT 1030 GDDR5
8gb DDR2

I just installed EOS and installed the steam package. Terminal installation went smooth and afterward it did the post install update when I clicked the runtime. Subsequently, when I try to actually launch the client, whether clicking it or running ‘steam-runtime’ in the terminal, it won’t load anything up. It’s running because I can see it as a task but nothing steam related comes up on the screen. After looking around I believe it has something to do with lib32-nvidia-utils being a higher version than my driver 495.46 but I don’t know how to downgrade packages. Pls help

Have you tried steam-native-runtime ?
This is what I normally use and have had zero issues with it so far
edit Just noticed in your screenshots mention wayland, have you tried under x11?

BTW Welcome to EndeavourOS

I think OP’s on XFCE and so X11. Would be nice to know for sure :+1:

1 Like

All I know is I always install the same way no matter the DE, though I have been using KDE for months now without switching back to XFCE (my other favorite de) on X11. The only issues I have ran across so far are with the actual games, not steam itself. The only time I have had issues with steam launching is with the Flatpak (from memory may be snapd, but pretty sure)

I had a similar problem after I downgraded my Nvidia drivers to v470. Is there a reason why you chose the v495 branch orver the current v510?

1 Like

I didn’t notice that til you pointed it out

I think the problem is a partial update. Try sudo pacman -Syu and apply all the updates and reboot.
nvidia-dkms should also be at 510 unless you intentionally downgraded it.

If sudo pacman -Syu doesn’t give you any updates, try to regenerate your mirrorlist as the one you are using (the first one in /etc/pacman.d/mirrorlist) seems to have issues.

Have you tried downgrading lib32-nvidia-utils?

To downgrade packages you can install the downgrade utility with yay -S downgrade after that you can run sudo downgrade nvidia nvidia-utils and you can choose the version from there