I can't shutdown/reboot. Authentication required

I don’t know what happened but suddenly I need to use sudo to reboot. I used to reboot using systemctl reboot and it just worked.

I get this error every time:
Call to Reboot failed: Interactive authentication required.

I’m not using ssh (I have it firewall blocked) and I already have a polkit (I’m using polkit-gnome).

I haven’t changed nothing in my sudoers file and everything should be the same. Before this problem, I installed cpupower and ananicy-cpp but they shouldn’t be related to this problem for all I know.

I’m using greetd (tuigreet) and loginctl outputs:

      3 1000 bigrand seat0 tty1 active no   -

id bigrand outputs
uid=1000(bigrand) gid=1000(bigrand) groups=1000(bigrand),3(sys),998(wheel),981(rfkill)

my sudo configuration:

[bigrand@bigrand-oem ~]$ sudo -ll
User bigrand may run the following commands on bigrand-oem:

Sudoers entry: /etc/sudoers.d/10-installer
    RunAsUsers: ALL
    RunAsGroups: ALL

Sudoers entry: /etc/sudoers
    RunAsUsers: ALL
    Options: !authenticate

Any ideas?

After sometime (I don’t how much) it does allows me reboot normally without requiring sudo.

EDIT: I lied. I don’t know how but in one of the attempts it did succeed, but I have zero idea why.

your not crazy. updated another distro on my hdd tonight, did my usual reboot, and I had to sudo to reboot.
the difference between us is 1) I just reboot, not systemctl reboot–both failed for us anyway
2) you got this Call to Reboot failed: Interactive authentication required. and I got a bunch of crap output in red with the word ‘inhibit’ over and over.

some popular package got updated in the Friday rush

you really want to know the weird part?
I been on Endeavour all day. This morning, log in, yay download updates, reboot, back to work.…it did not effect me on Endeavour like it do to you, only on another distro later in the day
“Forget it, Jake, it’s Chinatown.”

polkit just got updated on my end:

[2024-02-10T09:03:04+0100] [ALPM] upgraded polkit (124-1 -> 124-2)

Both systemctl reboot and reboot work fine after the update.

I am on GNOME and have only polkit (no polkit-gnome).

polkit-gnome seems to be required by cinnamon and xfce4-session but not by gnome.

polkit just got updated on my end

I got the update too and I thought it solved the problem but I was mistaken. Sometimes it works, sometimes it doesn’t. No idea why. Maybe it’s not even related to polkit.

I am on GNOME and have only polkit (no polkit-gnome).

polkit-gnome is a legacy version if I’m not wrong, but it works well (I’m not using GNOME though I’m using Sway but I don’t think that matters).

I really need some help here. I think it seems to be related to this, but I don’t know how to fix it, and I got a bunch of PAM errors in my journaltctl -b output

[bigrand@bigrand-oem ~]$ loginctl user-status
Could not get properties: Unknown object '/org/freedesktop/login1/user/self'.

journalctl -b output

I don’t know why, but I think ananicy-cpp was the problem. I installed ananicy config files because they are the defaults, but for whatever reason I was getting a lot of errors. I deleted the config files, and now it all works.

I could be wrong since the error sometimes doesn’t happen but I have been testing it for a while rebooting multiple times, and it seems to have been fixed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.