I can't make my HD writable


Please I need some help to fix my writtings permision on endeavour.

I have a Toshiba HD 500Gb but I can’t use it because it wont let me modifing any data. My disk have 2 partitions; the first partition was a btrfs in it I had another Linux distro (Garuda) but I formated that partition to use it within endeavour. The other partition works really well and it is in a ntfs format.

I’ve tried to make it work with this post Cant make hdd writabe but it didn’t work.

I also wipe and formated my partition with gparted to an ext4 format but this didn’t work neither.

I’ve tried to change permissions with

sudo chgrp adm /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b

sudo chmod g+w /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b


chmod 667 /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b

Thanks in advance.

Can you share the output of a few commands with us?

ls -l  /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b/*
findmnt | grep 615c68653b5b

Of course, and thanks for your help.

root@endeavour /r/m/e/2/lost+found# ls -l  /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b/*
                                    findmnt | grep 615c68653b5b
total 0
│ ├─/run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b /dev/sda1   ext4            rw,nosuid,nodev,relatime,errors=remount-ro

Ahh…the first command didn’t work. Can you try re-running the first and last commands with your normal user? None of those require root.

Ooops! I’m so sorry.
Here it is:

ehudd@endeavour ~> ls -l /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b/*
ls: no se puede abrir el directorio '/run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b/lost+found': Permiso denegado

ehudd@endeavour ~ [2]> findmnt | grep 615c68653b5b
│ ├─/run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b /dev/sda1   ext4            rw,nosuid,nodev,relatime,errors=remount-ro

ehudd@endeavour ~> groups
sys rfkill users wheel ehudd

You are not in the adm group so giving rights to adm won’t help.

Try this:

sudo chown -R ehudd:ehudd /run/media/ehudd/25aa53b2-829b-4d23-a3d2-615c68653b5b

Thank you it worked!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.