I can't log in to Wayland

Hi, although I have the possibility to access wayland, as soon as I do so the following screen appears. So even now I only run EOS in X11 mode. Is there a way to solve the problem? Thank you

Are you logging into Plasma (Wayland) from sddm?


Asking because that looks like the fallback xsession. I’ve run into that before, but it’s usually from startx and not specifying a wm in xinitrc.

Can you access journals from there? If not, can you jump into another TTY and do so?

I’m sorry but I understand very little of what you said. What could I actually do to fix it?

You no miss much !!
( :pray: my humor )

More info you can give , more chance you get someone that can/will try help you .

pls try read " https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/ "

:pray: i no use Plasma…

1 Like

Okay Thanks…

Sorry, just now seeing this. The link @Shjim provided is going to be helpful, but to get there you’ll need to have access to a console. Instead of trying to login from SDDM (your display manager or login screen), you should be able to access another TTY (not running X) with CTRL+ALT+F2/F3/etc.

You can also get logs from what you’re logging into above ^

Can you also try describing where the problem is occurring and your system info? Output of inxi -b should be a good starting point

Is it possible for you to provide the hardware output? Post the url from the command.

inxi -Faz | eos-sendlog

  Kernel: 6.8.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: initrd=\0e3273419bf64cf6a8f9732c955f44bc\6.8.5-arch1-1\initrd
    nvme_load=YES nowatchdog rw
  Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 20405 v: Lenovo Flex 2-15
    serial: <superuser required> Chassis: type: 10 v: Lenovo Flex 2-15
    serial: <superuser required>
  Mobo: LENOVO model: Lenovo Flex 2-15 v: 31900058 Std
    serial: <superuser required> part-nu: LENOVO_MT_20405_BU_idea_FM_Lenovo
    Flex 2-15 uuid: <superuser required> UEFI: LENOVO v: A0CN37WW
    date: 07/14/2015
  ID-1: BAT0 charge: 0 Wh (0.0%) condition: 12.8/31.7 Wh (40.3%) power: 6.7 W
    volts: 7.7 min: 7.2 model: SMP L13M4A61 type: Li-ion serial: <filter>
    status: charging
  Info: model: Intel Core i7-4510U bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 798 3: 800 4: 800
    bogomips: 20758
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; IBRS_FW;
    STIBP: conditional; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 840M] vendor: Lenovo driver: nvidia
    v: 550.67 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2024-04; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 2 speed: 5 GT/s bus-ID: 04:00.0 chip-ID: 10de:1341
    class-ID: 0302
  Device-3: Bison Lenovo EasyCamera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-4:3 chip-ID: 5986:0652
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,intel,nouveau,nv,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x044f built: 2014 res: 1920x1080
    hz: 60 dpi: 141 gamma: 1.2 size: 345x194mm (13.58x7.64") diag: 396mm (15.6")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel crocus drv: nvidia platforms: device: 0
    drv: nvidia device: 2 drv: crocus device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: crocus inactive: gbm,wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4400 (HSW
    GT2) device-ID: 8086:0a16 memory: 1.46 GiB unified: yes
  API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu
    name: NVIDIA GeForce 840M driver: nvidia v: 550.67 device-ID: 10de:1341
    surfaces: xcb,xlib
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  API: ALSA v: k6.8.5-arch1-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Lenovo Z50-75 driver: rtl8723be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 5000 bus-ID: 02:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 4000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Realtek RTL8723B Bluetooth driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-6:4 chip-ID: 0bda:b728
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 465.76 GiB used: 27.21 GiB (5.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
  ID-1: / raw-size: 464.78 GiB size: 456.41 GiB (98.20%)
    used: 26.97 GiB (5.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  Alert: No swap data was found.
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 8 GiB available: 7.67 GiB used: 1.9 GiB (24.8%)
  Processes: 185 Power: uptime: 9m states: freeze,standby,mem,disk
    suspend: deep avail: s2idle,shallow wakeups: 0 hibernate: platform
    avail: shutdown, reboot, suspend, test_resume image: 3.03 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd
    v: 255 default: graphical tool: systemctl
  Packages: 1453 pm: pacman pkgs: 1445 libs: 347 tools: yay pm: flatpak
    pkgs: 8 Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: konsole inxi: 3.3.34

Try to use code tags around the output you post to make it easier to read. I see it’s a hybrid laptop so it’s rendering on the Intel gpu. Nvidia drivers look like installed. Do you get a blank screen on laptop? Do you also have an external monitor hooked up to the laptop? If so have you tried it without the external monitor connected?

Hi, thanks for your interest. I don’t know what you’re referring to about Tags, anyway I don’t use any connected monitors and I don’t have a blank screen on my laptop.

Code tags are either using three back ticks ``` or three tilde ~~~ before and after the output you post or you can use the preformatted text button in the window. So what are screen images I’m seeing then just open terminal windows? Check if xf86-video-intel is installed with pacman -Qi fx86-video-intel if it is i would try uninstalling it and reboot so it runs on the kernel module instead of the intel driver. Not sure that will work but you could try.

Hi, in the end I solved everything by downloading a new updated ISO of EOS and reinstalling the system online. A radical solution which nevertheless allowed me to use wayland. Thanks for your support.