I can't install Artemis on my hard drive

Hello everyone, I’m trying to install Artemis on my hard drive of 80 GB, while my main hard drive of 1TB will keep staying in Windows10. I’ve booted the ISO of Artemis to my hard drive through Rufus and disabled Secure Boot. I turned on my laptop and started the installer of EndeavourOS, Calamar, selected the language, keyboard, etc., encrypt the system with a password, selected the only partition available for my hard drive (i.e. manual partition), then I created a new partition table with GPT and divided the partition like this:

  1. dimension: 512MiB; file system: fat32; mount point: /boot/efi; FS label: ; Flags: bios-grub and boot;
  2. dimension: 8192 MiB; file system: linuxswap; mount point: ; FS label: ; Flags: swap;
  3. dimension: 66,03 GiB; file system: ext4; mount point: / ; FS label: ; Flags: root;
    Then i proceeded to choose the packets (i choose Desktop Base + Firefox + i3-Window-Manager + Printing support + Support for HP printer/scanner), system name and credentials and at the end i clicked Install. But this error happened after less than 5 seconds:

Create a new partition table (type: gpt) on ‘/dev/sdb’

Job: Create new partition table on device ‘/dev/sdb’

Command: sfdisk --wipe=always /dev/sdb

I tried the whole process again but dividing the “root” in two parts made of “root” and “home”; but it gave me the same error. Then i read some topic on this forum and installed gparted to “umount” the hard disk but it says: umount: /run/archiso/bootmnt: target is busy.
Is there anything i can do? What am i doing wrong? I said everything i did and i hope i explained it well. Thank you very much for your patient

Welcome to community @andreaguido!

Reboot your system back into the Live session. Make sure you use UEFI mode.

Launch Gparted and create a new GUID partition table on your 80 GB drive.

Launch the installer and choose automatic install.

If it fails, use the log tool and get the URL for the install log and also your hardware info.

Post the URL on the forum.

Good luck!

:enos_flag: :handshake:t5:

1 Like

Thank you very much, I will try what you said and i will update you!

1 Like

with USB live Endavour
can you open a terminal, a browser on this topic
an report

inxi -Fza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
1 Like

Thanks for help Stephane, here is what the terminal output was after the three commands:

  1. inxi -Fza → it is a long list of all my laptop specifications
  2. test -d /sys/firmware/efi && echo efi || echo bios → efi
  3. sudo parted -l → Model: ATA TOSHIBA MQ01ABD1 (scsi)
    Disk /dev/sda: 1000GB
    Sector size (logical/physical): 512B/4096B
    Partition Table: gpt
    Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 274MB 273MB fat32 EFI system partition boot, esp
2 274MB 290MB 16.8MB Microsoft reserved partition msftres
3 290MB 986GB 985GB ntfs Basic data partition msftdata
4 986GB 987GB 1028MB ntfs Basic data partition hidden, diag
5 987GB 1000GB 13.4GB ntfs Basic data partition hidden, msftdata

Model: FUJITSU MHW2080BH PL (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 80.0GB 80.0GB primary fat32 boot, lba

sdb shoud be formatted in GPT
flag cant be bios_grub if mountpoint /boot/efi
it is boot & esp for /boot/efi

if you can choose only bios_grub
create 8Mo size with bios_grub ( not formatted )
/boot
/
/home

1 Like

Do you “burn” ISO to the harddisk you want to install the OS on? or using an USB stick?

I’m burning again the iso of EndeavourOS on my hard disk and this time I’m choosing GPT as you said. Anyway, considering that i can’t choose the flag and the mount point with gparted, I’m not inserting them; I can insert the only if i use Calamar during the installation

yes, i would like Endeavour on my second hard disk of 80gb, and my main hard disk of 1tb will keep staying in Windows10. I’m not using any usb stick

You will need one or a DVD as you can not install to the same disk you have the installer on.

oh that is the reason then… I’m feeling so stupid, thank you so much, it is since yesterday I’ve been trying everything. thanks again.
edit: but now I have a question: i save the iso on my usb stick and then i can install it on the hard drive, right?

1 Like

yes … that’s the common way to install almost any OS.

Okay thank you very much :+1:

Feel free to ask if you have any more questions.

And welcome at the Forum! :enos:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.