I can't get nemo to show desktop icons

Hello. I’m using budgie as my desktop environment, and I replaced nautilus with Nemo because I prefer it.

I added nemo-desktop as a startup command, but it doesn’t do anything.

if i run nemo-desktop on a terminal, this is the output i get:

** (nemo-desktop:6521): WARNING **: 01:24:46.010: Desktop already managed by another application, skipping desktop setup.
To change this, modify org.nemo.desktop 'ignored-desktop-handlers'.

EDIT: I got the desktop icons to show. I ran xprop and found the desktop-handler that nemo was complaining about, it’s called “budgie-desktop-view” but while the icons show up, i cant move them, or click on them, or interact with them in any way.

https://bbs.archlinux.org/viewtopic.php?id=241674

Take a look here, it may help

Welcome to the forum @ycid02 :partying_face: :enos_flag: :enos:

It was one of the first things I tried, didn’t help.

got the icons to show, but I can’t interact with them.

Managed to fix it:

At first I tried adding ['budgie-desktop-view'] to the ignored-desktop-handlers in dconf editor, that didn’t work (it kinda worked, but i couldn’t interact with the desktop icons).

Then i tried to disable budgie–desktop-view in dconf editor, didn’t work either

The solution in the end was to uninstall budgie-desktop-view:

sudo pacman -R budgie-desktop-view

Then restart

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.