I can't connect wi-fi on Deepin DE

Make sure there isn’t a key combination to disable WiFi like Fn+x

If all else fails you will need to get that machine online somehow. So either use a hardline to the router or use your cell phone as a tether. Then you can try another kernel. If that is an intel wifi adapter they are having issues on the newer kernels. Once online you can try:
In terminal:
sudo pacman -S linux-lts linux-lts-headers
Then:
sudo grub-mkconfig -o /boot/grub/grub.cfg
Then:
systemctl reboot
After reboot you should see 4 entries in grub. linux linux and it’s fallback image and linux lts and it’s fallback image. Select linux lts and boot into the system and see if you have wifi.

@mateus Could you post the output of lspci -k

systemctl status NetworkManager (forgot to start): https://pastebin.com/uVHAiJSQ
systemctl status NetworkManager (after I started the service again): https://pastebin.com/t9QQuvEz
lspci -k: https://pastebin.com/Ape18Myb

I will try tethering and kernel update as soon as I can

Cant boot with Linux lts.
I guess I should Just tive up dde for some time, not having success with this particular desktop in Amy distro

Your WiFi chip is Qualcomm Atheros and it looks like to me the broadcom-wl module is also loading, It is included with Endeavouros. (broadcom-wl)

I would try uninstall the broadcom-wl or blacklist it as your driver is ath10k. This is the module for your wifi. Someone can correct me if i’m wrong.

1. 02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

2. Subsystem: Lenovo QCA9377 802.11ac Wireless Network Adapter

3. Kernel driver in use: ath10k_pci

4. Kernel modules: ath10k_pci, wl

It say’s that atk10k is in use?

Edit: Maybe look at dmesg

dmesg | grep ath10k_pci
1 Like

I solved this problem in Deepin, like this: ignore/remove my WiFi and then write password again. Working without reboot!

1 Like

When I “have “ this problem I install another Dm , like gdm… to login and resolve this problem. Then you can remove gdm…
sudo pacman -S gdm
systemctl enable gdm
aystemctl start gdm

If is “failed to …” you must stop Lightdm first.

@mateus
Have you tried this?

Good day. Found this at YT, hope it can help just as it helped me. :slightly_smiling_face:

2 Likes

In reading some stuff on Arch, I felt on the solution with Wifi bug on Deepin DE :

https://bbs.archlinux.org/viewtopic.php?pid=1872921#p1872921

Open the file below :

/etc/NetworkManager/NetworkManager.conf

Then add these 2 lines :

[device]
wifi.scan-rand-mac-address=no

There is a part on NetworkManager called Configuring MAC address randomization more at the bottom of the page to setup more options and use different modes :

https://wiki.archlinux.org/index.php/NetworkManager#Configuring_MAC_address_randomization

6 Likes

This topic is also useful regarding the issue, just in case: https://bbs.archlinux.org/viewtopic.php?id=151985

Thanks this solved my WiFi kind of.
Every time I reboot the settings are lost for most items in the DDE.
It goes back to my guest WiFi.
Time resets the clock to 24 hour display
Audio resets to PC Speaker, and I am unable to play audio from my Intel HDMI.
All HDMI Outputs say unplugged and unknown or no.
Even though I am using the TV for my monitor.
I’m on a Dell Optiplex 7040 with an i7, 16 GB RAM, 500 GB SSD.
Maybe I should start another thread?
I’ve ran about 10 different distro’s on this mini PC with no troubles until now.

Does this behaviour also show on Gnome? I saw in another thread that you also installed Gnome, so I’m just curious if it is a Deepin or a Linux issue on your hardware.

If the problem also appears on Gnome, then you can try to install the LTS kernel

( sudo pacman -S linux-lts linux-lts-headers linux-headers)

Then reboot and select Linux LTS kernel in GRUB.

2 Likes

Also, don’t forget to update the bootloader after installing LTS kernel. In case of GRUB:
sudo grub-mkconfig -o /boot/grub/grub.cfg

Even if that won’t help to solve the issue it’s generally a good thing to keep LTS kernel around, just in case :slightly_smiling_face:

3 Likes

I can’t wait to have power back so I can try this stuff out :rofl:

1 Like

I did a full re-installation. Same issues with the DDE so I performed that LTS Headers install and I think fixed the HDMI audio. Thanks for the grub update reminder too. I still lose the AM/PM clock settings on reboot for some reason. I also still had to do the WiFi fix with NetworkManager.conf too again after a clean install. Probably Network adapter specific issue. I think the clock is a DDE issue with the project. The dock is the only place the setting exists so it is probably conflicting with the settings control panel. Probably needs added to the Settings panel of the DDE.

Deepin hasn’t been maintained for a while, its origin is in the city of Wuhan (where COVID-19 first broke out) so I guess they had other things on their mind.

1 Like

The new V20 Deepin would have to launch in mars but with Covid they announce april…Let’s hope they will update Deepin DE cause the barmenuseems to be an amazing system !

Deepin V20 will be the same than the version for Huawei UOS but without the support system and opensource like they always did before…

1 Like

I really like the software bundle on the Deepin OS too. Yeah I am patiently waiting for the new release.
I think the DDE as just a desktop bundled otherwise is just feeling like a theme skin. I’m having a lot of trouble with NVidia not recognizing on both the GNOME and the DDE. I have installed Conky and LM-Sensors on them both and can’t find the NVidia GPU even when I do install the NVidia support on the Live install. I tried multiple versions of Conky from the AUR and none seem to just work like the Ubuntu based apt installs. I struggle just trying to get Autostart of applications to work. I tried debugging running the conky’s from command line without any issues. They just can’t find the GPU.

Perfect solution for Deepin not reconnecting to wifi after suspend. Thanks!