I can't connect nor use any of devices in local network such as scanner and phone, but internet is working

I can’t connect to my phone via kdeconnect (my phone doesn’t show up), can’t scan using scanimage (my scanner doesn’t show up either) and print. Before that “lo” network showed up in NetworkManager out of nowhere (i think that’s when i lost the ability to communicate with devices in my network) and i made it invisible using this thread and then did a full system update that updated besides other things the NetworkManager, sane and cups. Tried to search it up but didn’t find anything that describes my problem. Nmap shows me that besides me there’s only two devices in network which is router and iptv connected to router with lan cable. Can’t quite understand what i need to do to fix it… I would be glad if someone could help me to get that working!

It sounds like you are on a different subnet than the other devices. Does your network have a guest VLAN, or anything like that?

Can you see this iptv from other devices on the network, for example your phone?

Have you tried reverting this change to see if the issue is related to it?

just checked on my phone with the same sudo nmap -sn command, and that iptv has .92 on the end in pc but .122 on the end in android. mac address is the same. still only 3 devices.

i did reverted it back (removing the file) and rebooted, it showed up as visible again but still can’t use anything

Is the WiFi network you are connecting to the same subnet?

Does your network have a guest VLAN, or is there only one SSID?

If you have access to the router, a worthwhile troubleshooting step would be to power cycle it and check for any changes in the network when it comes back up.

1 Like
sudo systemctl disable firewalld

Reboot, try again, if it works, re-enable the firewall and reconfigure it.

1 Like

i think they are, using ip addr on android it prints under wlan0, when on pc it prints, which is strange because

it can have one, i will check this later because i have to find the web configurator password

will try, thank you! :slightly_smiling_face:

already tried stopping the firewalld, configuring it to work with kdeconnectd and sane and others, and that was working until today, but thank you for trying to help!

1 Like

Instead of using DHCP on your router, it may make sense to assign fixed IP addresses to all devices. Try that, it should work much better. DHCP interferes easily with fixed IPs on a shared network, so fix them all, and the troubles might just be gone. :wink:

1 Like

that worked, thank you! :sweat_smile: still don’t get why that happened and why it happened just after an update (that coincidence is confusing)

my next step is to

, so I don’t become the iptv again

that thread has nothing to do with endeavour os then, thank you all

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.