I can't access my USB external hard drive anymore

So what happened was while i was moving some files around in it while I had Brave on with a tabs and while I was looking, my computer began to slow down and freeze. Brave had on some pretty heavy sites like YouTube and Discord. My laptop was also plugged in. I wasn’t able to close it because it was going so slow, so I had to force shut down. My USB hard drive was plugged in during that. When I powered it back on I then when I clicked on the USB hard drive icon then I got this,
I checked gparted and this is what it said

So yeah, dont be like me and have your browser have multiple, resource heavy tabs open with so many things plugged in to it.

Anyone have a quick fix?

Thank you.


1 Like

No quick fixes, no guarantees.

But I would do what it says in error message:

If you have access to a Windows system, plug in your disk and run a check on the disk:

chkdsk /f

Then reboot it twice.

From a Linux system, do some research about ntfs-fix. It might resolve some issues with NTFS filesystems:


1 Like

ntfsfix worked

… for now

I will definitely use what I experienced as reference on what NOT to do in the future.

Good night.


1 Like

Good to hear!

Please take a moment to mark the thread as solved by checking the solution box under the post giving the solution. This would help other users having similar issues to find the solution more easily.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.