I cannot find grub file

I am not able to find /etc/default/grub or /boot/grub/grub.cfg. Also the grub-mkconfig command is not found.

That is because EnOS’ default bootloader is systemd-boot and not Grub.

If you tell us what you want to do, for example in /etc/default/grub, we may be able to help you.

I want to turn off acpi option in grub

Alright.

Please read carefully through the article linked to below and specially the quoted part further down:

https://discovery.endeavouros.com/installation/systemd-boot/2022/12/

How to modify kernel options

In systemd-boot, it is actually quite simple. You edit the appropriate entry file which can be found on your EFI partition in the loader/entries directory. Each entry is a boot option on the menu and each has a line called options. You can modify these entries directly, however, these changes may be overwritten when packages are installed or updated.

To make the changes, instead of modifying the entries, modify the file /etc/kernel/cmdline which is a one-line file containing a list of kernel options. Then run sudo reinstall-kernels which will populate the entries and regenerate the initrds.

If you would prefer to use the current kernel options from the running system, you can instead rm the file /etc/kernel/cmdline and then run sudo reinstall-kernels.

PS.
You may also want to edit the title of the topic to reflect the actual issue you are trying to resolve. Thanks!

I think it would be as simple as adding acpi=off to the kernel command line and running the command to reinstall the kernels.

I assumed that OP knew this part but nice you have pointed that out.

1 Like

I don’t know much but i do know one thing. Never assume! :laughing:

Edit: With you I know what you know and that’s more than I do. So i don’t have to assume! :rofl:

1 Like