I cannot assign key shortcut on Settings > Shortcuts > Custom Shortcuts

So, I need to asign the Print Screen key for taking screenshot with Flameshot, and I don’t know if it’s this version of KDE being buggy, but I cannot assign it on Settings > Shortcuts > Custom Shortcuts. I keep clicking None button, but nothing happens after pressing any key:

KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.3-arch1-1

What should I do?

I’m pretty sure it’s an issue in Plasma. I have the same issue on all my Endeavour machiens, along with Debian Bullseye (also on 5.20.4), and KDE Plasma (also on 5.20.4). If you have anything on an older version, you can go in, assign the keystroke, export it, and then import it, that’s how I’ve been getting around the problem.

1 Like

Do you have the package khotkeys installed?

EDIT: Looks like it is a bug
https://bugs.kde.org/show_bug.cgi?id=430388

I don’t have any machine with an older KDE version, but I can try to install Debian or Kubuntu on VirtualBox and exporting it from there…

Yes, I already had them installed:
image

Apparently… Let’s hope it gets fixed soon.
Thanks!

also spectacle installed?

it got here standard print…

Yes, but I don’t like Spectacle… I find Flameshot a lot more convenient.

2 Likes

Agreed on that, although for me it’s Ksnip. Spectacle is just…lacking. Why go through multiple applications to do simple annotations such as adding texts, arrows, highlights, etc? Flameshot/Ksnip adds this abilty so that you can take your screenshot and do extremely basic edits it quickly in 1 shot, rather than going from app to app.

1 Like

Yeah, it’s for that and because I’m finding it much easier to copy the screenshot, I just have to press CTRL + C on the selection and done.

And by the way, issue fixed! I have exported the shortcuts config from Kubuntu and now Print Screen key works after having imported it on Endeavour. Thanks @tlmiller76!

1 Like

ok found something as :ok_hand:

just a workaround seems it has for some time…

just make a custom then go to the other short keys and find your key then you can set a key. for future reverense if not is fixed… :slight_smile:

1 Like

Mmm, so in my case the command I have to run for taking screenshots with Flameshot is flameshot gui, but if I type that on there, I don’t see anything like that :man_shrugging:

What you do to use the way Ringo found is go in and Create the “custom shortcuts” and set the command to use. THEN go into the “custom shortcuts service” in Shortcuts, find the custom shortcut you set, and set it there. Just tried it on Debian Bullseye and it does indeed work. Haven’t tested on Endeavour, but betting it would since every OS I was using had that issue.

when you mlade a custom, and apply, with out a key

then go to shortcuts then search for your key name you will list is

is a work around there are post on kde post with this issue, it just a workaround it works… without must doing export/import

but shortcuts has more bugs… but thats with azerty belgium keyboard :slight_smile: kwin strikes it back when i manually change it :slight_smile: nvm…

but your custom keys should have a proper name it should find in shortcuts

before posted this i tried, currently using kde itself but no panels… (hiding) and no window borders :slight_smile:

before posted i tested this workaround seams to work… found also out it didnt work properly the custom keys

Ohh alright, I get what you mean… I have just tried it on Endeavour and yes, it works, so it should work for everyone as well. That’s indeed better than exporting/importing.

1 Like