I can boot only into emergency mode

I have a dual boot notebook with Win11 and EOS. I don’t know what exactly caused this, but after a reboot, I can only boot into emergency mode.

My journalctl messages are here:

I tried to re-install grub (with os-prober via the install USB stick), but this did not help.

Could anyone please give me a hint what to do next? Which information do you eventually need to help?

What error are you getting at the point at which you are dropped into emergency mode?

Hi Dalto
On the screen is no direct error message. The last line before is:
[ OK ] Mounted /boot/efi
You are in emergency mode. After logging in, type…

(and the rest of the text). I have to enter the root pwd and reboot.

The journal says:

Dez 29 20:13:02 hppro systemd[1]: Dependency failed for Local File Systems.
Dez 29 20:13:02 hppro systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
Dez 29 20:13:02 hppro systemd[1]: local-fs.target: Triggering OnFailure= dependencies.

That’s not really good. What have you done? :scream:

Have you chrooted successfully for this?
If you can chroot, check your filesystem (lsblk -f, fdisk -l, etc.).

I am sure it is something you did, just before rebooting (installing/uninstalling packages, changing system configuration, removing/installing hardware, etc.). You are the only one that knows… :person_shrugging: Think! Think! :joy_cat:

Before os-prober, I successfully arch-chrooted. I can even access to the whole filesystem in emergency mode after logging in as root.

When thinking about what I have done before (well, after the last reboot, which was about 2 days before - I usually switch my system to standby mode), two things come into my mind:

  1. I installed some software, e.g. VirtualBox
  2. Before it went to emergency mode, I booted once Windows 11, then shut down normally, then wanted to boot EndeavourOS, but Windows booted again (I forgot to hold the F9 shortcut for the boot menu). I was a bit angry about Windows booting again and hard-switched the notebook off (held 5 seconds on the on-off-switch). Just after this came the emergency mode.

Is there any way to get the installed EndeavourOS again to work normally or do I have to make a backup and then a fresh install of the whole EOS again?

I “solved” the problem by re-installing EndeavourOS on the same partition. It re-installed also the EFI partition and now, I can boot again. Most of the software could be re-installed and the backup gave me a lot of configurations back, so I did not need to re.configure all.
Next time, I will be more careful when booting - no more cold switch off while Windows boots. I hope this will avoid similar problems.
Thanks to all who tried to help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.