I am unable to change the refreshrate of my 240 hz monitor to 240 hz

I have been trying to get 240 hz on my current build but I am running into some trouble.

The max refresh rate that is able to be identified is 120 hz at 5120x1440 res. Some of my other resolutions have 240 hz available.

I have already tried.

  • made a 10-monitor.conf file.
  • adding custom refresh rate via cvt and adding mode to xrandr (got errors)

Here is my xrandr output.

Please let me know what I need to post in order to help my case. Thanks in advance!

I depends …

Is the monitor Samsung Odyssey G9?

I am using such monitor - and getting 240Hz is next to impossible.

Doesn’t it sometimes depend on the monitor if a refresh rate is possible on a certain resolution?

We need the monitor name.

If you mean the actual name of my monitor I am using the Samsung Neo G9. I run 5120x1440@240hz on windows with no problem.

Yes, I am using the Samsung Neo G9. Thats odd because my second monitor isn’t having any issue running at 165 hz (switched it after taking the SS).


Disable G9 Adaptive Sync and try.

Edit You also don’t say what graphics card and desktop you have installed. Please provide the hardware info. You can post the url.

inxi -Faz | eos-sendlog

When I disabled Adapt. Sync the option for 120 hz became available. Here it is. https://0x0.st/H-8j.txt .