I Am Stuck, Lost and Unsure

So. Been using Linux Since the mid 90’s. Started with Mandrake and red hat. Have experimented with many different versions, including “Lindows” if anyone remembers that. I do not claim to be very knowledgeable at all ( i am a user not a programmer). I used Ubuntu for a few years and Lubuntu on a couple very old computers. I did some research on Arch Linux and decided I liked the endeavouros version. I do not dual boot, I cannot stand windows although the world is centered around it. I have even put my work computer in my office running linux (now endeavouros). Here is my problem and maybe I am just a dummy that should not be using something over my head:

-acer Nitro 5 lappy, installs. sees Geforce GPU with 535 drivers. Lutrus and Steam programs run great, No issues.

-same with my PC that I have HDMI to my TV, and a couple other newer PC’s.

-I have 2 PC’s that are a tad older. One with a GeForce 9600 and the other with a 710 slim. Needless to say, 535 has no support for these cards so here is my efforts:

yay -S nvidia-Driverxx-utils nvidia-Driversxx-dkms AUR packages on both computers. NO JOY!

sudo pacman -S install XXXXXX Works but NO JOY!

Nvidia-inst No JOY!

no GPU Found when executing certain things that require the GPU Specific drivers and not the nouveau

a couple of things do install then I get a very long log file that only allows me to ctrl C to exit (should i save? if so how?). there are no issues and everything looks good but graphic card is still not installed although drivers are there and appear installed. I have tried every driver package associated with these cards listed in the AUR repository. I have tried every install command I can find on the net, nvidia-installer (which is no longer good) and nvidia-inst. Same thing everything goes good, I replace ALL packages and rebuild no errors. There is no Graphic card associated with anything I try to run in Lutris especially Diablo IV.

NO GPU FOUND is the problem

Log out of os, shut down X Server, systemctrl stop lightdm. Run:

sh NVIDIA-Linux-x86_64-340.108.run directly from NVIDIA, the installer writes a conf file to stop noveau in 2 places. I have tried with updating kernal it fails updating lts kernal, and without updating kernal and the installation always fails at 20% of building NVIDIA kernal.

after the fail I cannot boot to the os it just hangs until you ctrl alt f2 and delete the 2 files the installer created and then we are back to square one.

I have broken the OS many times and reinstalled more that I wish to say as well as tried many things not listed in this post.

any Suggestions?


1 Like

Boot on the live ISO and provide the hardware info with Internet.

inxi -Faz | eos-sendlog

Found this:


Contains a lot of useful info on which card is which architecture.

Yes this is good. I just wanted to see the hardware info to confirm exactly.

Yeh, I looked up the names. Pretty new to nVidia, not had one since the mid 1990s, now have a RTX3070 mobile, so still learning :smiley:

Apparently mine is an “Ampere” :rofl:

I don’t see the 4000 series listed. Wonder what they are called. I have a Pascal GTX 1060

“Ada Lovelace”. Sometimes referred to as just “Ada”

1 Like

Thanks for links and info, Will research more.

So, I just wanted to let you know that the info and links provided me with the info I was seeking. I was successful in accomplishing the installations and they work as expected. there were a couple of necessary items that I was not doing before, and the links detailed them out. Again, thank you very much!!