I already make swap on installation but it won't mounted

So I have my laptop installed EOS recently. On process installation I am very sure that I’ve select some of my partition as swapfile. But after the installation is finish, there is a swapfile created but I need to active it manually to make it work by KDE Partition Manager or else it won’t active. I already search through the internet and couldn’t find the possible solution. Please help, which command output should I post here? Thanks

A swap file and a swap partition are two different things that are set up in different ways. It is unclear which one you have because you have said swap file, but are also talking setting up a partition for it.

This command will clarify what kind of swap is in use:

swapon --show

If you have already activated the swap device with swapon, add an entry to /etc/fstab and you should be all set.

Like this for a swap partition:

UUID=*device_UUID* none swap defaults 0 0

Like this for a swap file (use the path to the swap file):

/swapfile none swap defaults 0 0

Reference for swap partition: https://wiki.archlinux.org/title/swap#Swap_partition
Reference for swap file: https://wiki.archlinux.org/title/swap#Swap_file

I think it was swap partition. You know the thing that work like RAM but using your disk.

I already input the command and there’s no output. That mean I should follow the link about swap partition correct?

Yes, if you have the partition set up already but it hasn’t been set up as swap yet you should follow those instructions to set it up.

It’s pretty quick and simple, just make sure you know what partition it is (run lsblk or similar to help identify it).

sudo mkswap /dev/sdxy

Substitute sdxy for your swap partition.

Enable the swap device:

sudo swapon /dev/sdxy

If you have a GPT disk, that’s all you need to do. If you are on a legacy setup, you should add an entry to fstab as well.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.