Hyprland VScode always starts with editing --ozone-platform-hint=wayland and --disable-gpu

i im still new to endeavour, i wanted a quick way to try hyprland and i found that installing EOS + hyprdots install script was the fastest way and i ended up loving it.
i’ve ran into many problems which i seem to end up fixing using the arch wiki and the internet overall.
but now whenever i open Code-OSS it always opens editing two empty files, one is called --ozone-platform-hint=wayland and the other is --disable-gpu.
240424_21h53m54s_screenshot

It looks like improperly passed command line arguments.

How are you opening it?

whether I’m opening it with Super+C, open folder with, open file with or just the usual executable it always opens like this.
thank you for your response! and sorry to bother you with something that sounds dumb and stupid>

What does the Exec line from the .desktop look like?

This will open files / editor buffers with these names:

code -- --enable-features=UseOzonePlatform --ozone-platform=wayland

This will pass them as CLI arguments:

code --enable-features=UseOzonePlatform --ozone-platform=wayland

it looks like Exec=code-oss --unity-launch %F under [Desktop Entry]
and Exec=code-oss --new-window %F under [Desktop Action new-empty-window]

I’m not entirely sure where the extra flags are popping in from, but if at all you need custom flags, they should go in ~/.config/code-flags.conf.

When using a per-user configuration, both visual-studio-code-binAUR and code read ~/.config/code-flags.conf. Note that this is specific to these packages, as they use a patched loader script that reads these options.

From Arch wiki: https://wiki.archlinux.org/title/Visual_Studio_Code#Running_natively_under_Wayland

Edit:

Seems like hyprdots puts it by default

1 Like

I did find the arguments in ~/.config/code-flags.conf so i tried removing them, it seems to have fixed the issue, VSCode now works as intended.
Thank you so much for your help lads!
Good luck to everyone!

2 Likes

HornyPepporoni is a lot of syllables when you say it, but after you say it, it’s rewarding and I smile.

1 Like

It’s just a random username i made up when i was 13 years old, and it just stuck with me ever since lmfao.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.