[Hyprland] QT theme not applying to all apps

I switched to Hyprland from KDE some time ago but i faced an issue the QT theme i specified only applys to some apps and not all of them, I set these enviroment variables:

env = QT_QPA_PLATFORM,wayland
env = QT_STYLE_OVERRIDE,kvantum 

Here is an example of this problem:

And here is what a qt app should look like:

The latter (QBittorrent) applys the theme as intended but the first app (protonup-qt) doesnt.


Protonup used Qt6. That’s why it’s not working.

You will need to install a Qt6-compatible theme and theme manager, like qt6ct and/or kvantum.

It is strange that it doesn’t work though, since qBittorrent also uses Qt6. Is your installation of Protonup a flatpak or from the AUR? If it’s the flatpak version, try the one from the AUR or build it from source instead. The AppImage should also work just fine.

I am using the AUR package for protonup-qt

Also the above variables contain a qt style override to make it all kvantum


Yes, but it is pointing to qt5ct instead of qt6ct. Try changing that, then log out and log back in to see if it makes a difference. Assuming you have qt6ct installed.

Like I said, protonup should be themed correctly already because qBittorrent uses Qt6, but seeing as it’s not themed correctly, I’d give it a shot.

Tried it no effect also qt6ct said the qt style override was interfering so i tried commenting the line and still no effect

also QT6CT is supposed to work too when the env var is set to qt5ct

Again, I know it’s supposed to work. Was trying to see if there is something weird going on.