Hypnotix IPTV not working

anyone with experience using Hypnotix?

I had it installed and setup with my IPTV player but the buffering logo in the video area just persisted the entire time and an actual video never played.

That was with the Hypnotix AUR repository.

So I uninstalled it and I tried the hypnotix-git and that one won’t even open when I try to run it.

I had the same problem. Ended up installing iptvnator from AUR. It works for me as expected.

Glad to know it wasn’t just me.

I also have iptvnstor running with mpv.

It’s clunky how the video is played full screen in another window.

I guess I need to stop complaining

Hypnotix doesn’t work for me either. It starts up, but I can’t see any channels. Starting it from the terminal I get this:

> [sermor@sermor-eospc ~]$ hypnotix
System version of yt-dlp selected.
[sermor@sermor-eospc ~]$ Free-TV: 1611 channels, 89 groups, 0 series, 225 movies
TV: 926 channels, 39 groups, 0 series, 26 movies
Italy: 432 channels, 4 groups, 0 series, 0 movies
Caricamento dei provider...
Free-TV: Recupero playlist...
Free-TV: Controllo playlist...
Free-TV: Caricamento canali...
TV: Recupero playlist...
TV: Controllo playlist...
TV: Caricamento canali...
Italy: Recupero playlist...
Italy: Controllo playlist...
Italy: Caricamento canali...
No flag found for: Documentaries (AR)
No flag found for: Documentaries (EN)
No flag found for: News (AR)
No flag found for: News
No flag found for: Business
No flag found for: Weather
No flag found for: News (ES)
CHANNEL: 'Rai 1 Ⓖ' (https://mediapolis.rai.it/relinker/relinkerServlet.htm?cont=2606803&output=7&forceUserAgent=raiplayappletv)
Exception in thread Thread-3 (play_async):
Traceback (most recent call last):
  File "/usr/lib/python3.12/threading.py", line 1073, in _bootstrap_inner
    self.run()
  File "/usr/lib/python3.12/threading.py", line 1010, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/hypnotix/hypnotix.py", line 908, in play_async
    self.mpv.play(channel.url)
  File "/usr/lib/hypnotix/mpv.py", line 1648, in play
    self.loadfile(filename)
  File "/usr/lib/hypnotix/mpv.py", line 1151, in loadfile
    self.command('loadfile', filename.encode(fs_enc), mode, MPV._encode_options(options))
  File "/usr/lib/hypnotix/mpv.py", line 1043, in command
    _mpv_command(self.handle, (c_char_p*len(args))(*args))
  File "/usr/lib/hypnotix/mpv.py", line 133, in raise_for_ec
    raise ex(ec, *args)
ValueError: ('Invalid value for mpv parameter', -4, (<MpvHandle object at 0x7a07095fe7d0>, <mpv.c_char_p_Array_5 object at 0x7a07095feed0>))

On Htpnotix for MPV settings I have this, it should be the default option (I haven’t touched it):

I also tried installing the iptvnator package but nothing changed. How can I solve it?

The solution given here :

worked for me.