HTOP won't start (Cinnamon, Tilix)

I did a barebones install of Cinnamon and I just discovered an annoying little hickup: Htop won’t start when I click on the icon for it. My only terminal (and yes it is set as preferred terminal) is Tilix. Not sure if that matters.

I had this also in Gnome a while ago, have you tried to reboot the computer?

Not for a bit. I’ll do that before complaining again :wink:

1 Like

No such luck I’m afraid. Not a big problem, I run it very rarely.
Though come to think of it, I need a system monitor. Is Cinnamon usually running the gnome one?

Have you installed Gnome also and with this I mean just Gnome and not Gnome-extra, Cinnamon tends to run better with Gnome installed also.

No, I have not. Though this is the only thing not working at the moment. I will keep it in mind, however.

1 Like

if you are using the icon to launch htop it means you are not necessarily adverse to using GUI so here are two alternatives:
the first one is lxtask the second one is xfce4-taskmanager (for LXDE and XFCE respectively. maybe Cinnamon has something like it if you don;t care to pull the prerequisites for one of the above, although lxtask should really have thin prerequisites).

i think is just same as https://github.com/linuxmint/cinnamon/issues/5269#issuecomment-354670916

even you have tilix as prefered terminal it want to look to gnome-terminal if not xterm whatever it follows… try to look dconf-editor ?

lxtask is less debs indeed, but personal i think if you install gnome-system-monitor is also not to much , as you use telegram-desktop as example some depency also needed… depends how you share it ? personal i avoid webkit2gtk so cinnamon is not for me, as zenity i use the gtk2 version with no webkit2gtk as example :slight_smile: but some likes htop, so probably it looks the terminal in order. in standard preferences does not work ootb that way i think.

Htop will work with gnome-terminal

Yeah there was a thread about it already. Cinnamon is automatically set to use gnome-terminal, so you need to find out how to change that to your prefered terminal or simply install gnome-terminal.

or just create your own launcher… htop.desktop file inside ~/.local/share/applications/

[Desktop Entry]
Version=1.0
Name=Htop
Type=Application
Comment=Show System Processes
Comment[ca]=Mostra els processos del sistema
Comment[de]=Systemprozesse anzeigen
Comment[en_GB]=Show System Processes
Comment[es]=Mostrar procesos del sistema
Comment[fi]=Katsele järjestelmän prosesseja
Comment[fr]=Affiche les processus système
Comment[gl]=Mostrar os procesos do sistema.
Comment[it]=Mostra processi di sistema
Comment[ko]=시스템 프로세스 보기
Comment[nb]=Vis systemprosesser
Comment[nl]=Systeemprocessen tonen
Comment[nn]=Vis systemprosessar
Comment[pl]=Pokaż procesy systemowe
Comment[pt]=Mostrar os Processos do Sistema
Comment[pt_BR]=Mostra os processos do sistema
Comment[ru]=Просмотр списка процессов в системе
Comment[sk]=Zobraziť systémové procesy
Comment[sl]=Prikaz sistemskih opravil
Comment[sr]=Приказ системских процеса
Comment[sr@ijekavian]=Приказ системских процеса
Comment[sr@ijekavianlatin]=Prikaz sistemskih procesa
Comment[sr@latin]=Prikaz sistemskih procesa
Comment[sv]=Visa systemprocesser
Comment[tr]=Sistem Süreçlerini Göster
Comment[uk]=Перегляд системних процесів
Comment[zh_CN]=显示系统进程
Comment[zh_TW]=顯示系統行程
Terminal=true
Exec=tilix -e htop
Icon=htop
Categories=ConsoleOnly;System;
GenericName=Process Viewer
GenericName[ca]=Visor de processos
GenericName[de]=Prozessanzeige
GenericName[en_GB]=Process Viewer
GenericName[es]=Visor de procesos
GenericName[fi]=Prosessikatselin
GenericName[fr]=Visualiseur de processus
GenericName[gl]=Visor de procesos
GenericName[it]=Visore dei processi
GenericName[ko]=프로세스 뷰어
GenericName[nb]=Prosessviser
GenericName[nl]=Viewer van processen
GenericName[nn]=Prosessvisar
GenericName[pl]=Przeglądarka procesów
GenericName[pt]=Visualizador de Processos
GenericName[pt_BR]=Visualizador de processos
GenericName[ru]=Монитор процессов
GenericName[sk]=Prehliadač procesov
GenericName[sl]=Pregledovalnik opravil
GenericName[sr]=Приказивач процеса
GenericName[sr@ijekavian]=Приказивач процеса
GenericName[sr@ijekavianlatin]=Prikazivač procesa
GenericName[sr@latin]=Prikazivač procesa
GenericName[sv]=Processvisning
GenericName[tr]=Süreç Görüntüleyici
GenericName[uk]=Перегляд процесів
GenericName[zh_CN]=进程查看器
GenericName[zh_TW]=行程檢視器
Keywords=system;process;task

2 Likes

Preferred terminal is changed. But I’ll look in dconf.editor i guess. Or just type “htop” :wink:

I installed gnome system monitor: It matches the native Cinnamon apps and has barely any extra things pulled down since Cinnamon runs on a customized Mutter.

Duh. Realized that it worked in Xfce terminal. My guess it’s one of those apps that has a list of 4 or 5 terminals it looks for and Tilix isn’t among them.

i think rater is a bit of cinnamon issue ? i set tilix as prefferable terminal while stil qterminal installed :slight_smile: but after boot running htop, it took the tilix terminal

2 Likes

So question is: install a second terminal just to trigger htop to open tilix or just type the command?

I’d just type it then, I think. :slight_smile: thanks for the information though.

mayby this evening wilt try a bare cinnamon with tilix =) in virt-manager, but will see if dconf-editor does, since cinnamon also focussed on that… but dont think its a htop issue, lxqt worked with tilix ootb if i select it… it doesnt show but can select it.

1 Like

its not a htop issue it is only that gnome-terminal is not installed so it can’t be launched… the default htop.desktop file (launcher for menues) includes only:

Terminal=true
Exec=htop
Icon=htop

so it is calling DE default choosen terminal in the case of cinnamon gnome-terminal to launch htop e.g.
gnome-terminal -e htop

you can try to change default terminal to use ( not working with GNOME as it is hardcoded inside apps) or change the exec-line inside the launcher (desktop file) … e.g. you can add personal custom launchers inside your home under ~/.local/share/applications/

you can copy default desktop file at home:

cp /usr/share/applications/htop.desktop ~/.local/share/applications/

and edit the EXEC line:

Terminal=true
Exec=tilix -e htop
Icon=htop

this will launch it inside tilix then…

2 Likes

GOT IT.

Stupidly simple: I went into Cinnamon’s built in menu editor, changed the menu item for htop to:

Uncheck “Open in terminal”
Run command “tilix -e htop”

Voilá!

1 Like