Hplip-plugin for scanning not working

Hello, I have an old multi function printer that scans w/o problems in Ubuntu and Fedora. The hplip-plugin does not install either via hplip or via aur (which has a different version). I have seen a similar problem in Manjaro. I suspect, if we fix it now, it might re-appear in half a year. Any recommendations? Thanks!

2 aur/hplip-plugin 3.20.5-1 (+381 3.45%) (Installed)
Binary plugin for HPs hplip printer driver library
1 extra/hplip 1:3.20.5-2 (18.8 MiB 30.7 MiB) (Installed)
Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet

why hplip-plugin from AUR?
use hplip itself, only issue currently is that it fails to get key for validating downloaded plugin, and fails caused by that.
But can be solved simple:

sudo nano /usr/share/hplip/base/validation.py
change the server in the line:

def __init__(self, pgp_site = 'keyserver.ubuntu.com', key = 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9):

the keyserver they are using per default is failing currently

1 Like


Very good!

use hplip itself

but how to get hold of it? Thanks.

I suggest to add a section on the all important hplip-plugin.

sudo pacman -S hplip

the receive key error is a bug happen currently to more then one procedure needing to download keys from keyservers, they are bad in response.

Problem solved! Following your instructions and then download the plugin through hplip works. Scanning works, too. However, I am getting this message which is probably save to ignore.


yes if there is no it can not be used… you are running GNOME?

i do add hp-printer section to the wiki :wink:



Yes, that explains it.

Unfortunately, that fix ceases to work. Any ideas or log files to look at? Thanks.

That solution seems to have ceased to work. It is looking for the keyserver forever. Any ideas? Thanks.

Following this link

/usr/bin/gpg --homedir /home/$USER/.hplip/.gnupg --no-permission-warning --keyserver pool.sks-keyservers.net --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9

seems to fix it. Indepently, I have seen on aarch64 Ubuntu a


w/o a hex key that also seems to work.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

yea :old_key: :ring: issue with hp keys coming up from time to timei thanks for sharing :vulcan_salute:

it is in the printer wiki already on the bottom: