HPLIP and file PPD

Hello. I just installed Linux Endaevour. With HPLIP I am trying to install my HP network printer. My printer has an IP address and I ping it. In ‘manual recovery’ HPLIP finds my printer at this IP address but it is impossible to link the PPd file which is in usr / share / ppd / hp. HPLIP does not take it. What should I do?

Did you do the initial configuration?


[papa@pcpapa ~]$ hp-setup

HP Linux Imaging and Printing System (ver. 3.19.6)
Printer/Fax Setup Utility ver. 9.0

Copyright © 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

qt5ct: using qt5ct plugin
Searching… (bus=net, timeout=5, ttl=4, search=(None) desc=0, method=slp)
error: No devices found on bus: net
error: HPLIP cannot detect printers in your network. This may be due to existing firewall settings blocking the required ports.
When you are in a trusted network environment, you may open the ports for network services like mdns and slp in the firewall. For detailed steps follow the link.
Manual recovery :
Found device: hp:/net/Photosmart_5510_series?ip=
error: No PPD found for model photosmart_5510 using old algorithm.
error: No appropriate print PPD file found for model photosmart_5510_series

The ppd file exists in ‘usr / share / ppd / hp’ but hplip refuses to take it.

I solved my problem by applying this:


Esto se hace desde la terminal con:

sudo pacman -S cups gutenprint foomatic-db foomatic-db-engine foomatic-db-nonfree foomatic-db-gutenprint-ppds foomatic-db-ppds foomatic-db-nonfree-ppds splix

Luego, habrá que iniciar el servicio de impresión. Esto se hace con:

sudo systemctl enable --now org.cups.cupsd.service


I have an HP Envy 5640, and this worked perfectly for me. Thanks!