HP Printer Can't Get Wireless Working

I’ve tried with the printer cable plugged in to set it up but EOS doesn’t find it in the WIFI setup

It’s like something is blocking it but don’t know what it might be.
No problem printing with the USB cable.


I found that page earlier and followed that but still not working. I just did everything again but get…

Do you have it set up as per the wiki?

Edit: More info …


Edit: Have you tried with this selection?


On that page I had already setup Avahi and it’s running. A lot of the other things there I’m not familiar with.
Tried several times to setup wireless with the USB cable hooked up.

What do you mean?

Like adding services, obtaining IPv4LL IP address, configuring mDNS for custom TLD, NFS, Vsftpd, Samba, etc.

Did you edit the following?


Change so it say’s this?

mdns_minimal [NOTFOUND=return]

Yes I edited that file when I first started trying to get the wireless working.

I wish i could be more helpful but i don’t have one of those printers to try and see what the issue is. Usually it’s something simple maybe overlooked. :person_shrugging:

I’m not that familiar with HP printer setup but did you use hplip?

Yes, I installed that driver. Seems something is blocking the wireless. I thought it might be the firewall and turned that off but didn’t help.

Well, not sure what happened but I tried Manual Discovery again in the HP Device Manager, entered the IP address again and Wifi printing is working now :grinning:

Thanks for you replies and help! It might been going through all the settings again you pointed out and something I missed before.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.