[howto:] Disable Thunar Compact view filename shortening

For those of you who uses Thunar compact view but don’t like the new filename shortening you can disable that like this (found it on internet)

In thunar, with compact view long filenames are truncated and an ellipsis (…) inserted in the middle
I didn’t like this feature, and found no documentation so I thought I would share what I found.
There is a hidden setting, misc-compact-view-max-chars. Set it to 0 or a negative number to disable truncation. Default is 50.
It wasn’t in the list in xfce4-settings-editor so I had to add it. That can be done in that editor

Go to xfce settings manager/thunar and click add
Propertyname: /misc-compact-view-max-chars
Type: int
Value: 0

Or by terminal:
xfconf-query --channel thunar --property /misc-compact-view-max-chars --create --type int --set 0