How well does Picom work for you all (on nvidia)?

For me, picom has caused a ton of issues in games, it’s always causing stuttering and the like. It also is causing ghosting on windows for me. Messed around with a few settings but the only one I noticed to be any effect was setting the backend to xrender

I’m no longer on Nvidia but was until a couple of months ago. I had no issues with picom at all during that time. I did always kill picom before playing games (so as to remove transparency).

I am on Nvidia but don’t play games. Never had an issue with Picom.

Also you might have better luck with steamos-compositor-plus given how it’s made for a “gaming OS”.

I’m having to do that as well, guess it’s good to hear its not just me

Have you tried it at all?

I did and it ended in disaster.

A vertically elongated black rectangle appeared from which the mouse cannot escape. But then again I have a very old system. Try it out for yourself.

Same exact result

I don’t have nvidia, but I play games sometimes on my xfce install with picom. To me the best solution is to toggle on/off picom when I play. This bash script is perfect for me:


if [ `pgrep -x picom` ]; then
   notify-send -t 1600 'Disabled picom' --icon=video-display
   killall picom;
   notify-send -t 1600 'Enabled picom' --icon=video-display
   picom -b &
1 Like

I think most people just disable compositing when gaming. But, you could try enabling full composition pipeline in your nvidia settings

I am on Nvidia drivers and I use backend = "glx" and unredir-if-possible = true. Disable blur for games if the performance is not improving.

Edit: forget to mention that force full composition pipeline is on and games runs pretty smooth

sadly im on an optimus laptop so nvidia-settings cant manage my laptop screen. xcompmgr seems to work a lot better than picom for me