How to up Japanese ibus-anthy on GNOME 45.0? a quickstart guide from a newbie

this is a posible solution to This issue

what i did to set it up:
Install anthy: yay -S ibus-anthy

Run: ibus-setup

Add the next lines to the .bash_profile file:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

setup anthy at my likings adding the custom font: SourceSansHanJPBold (as far as i know you can set it up as you would like and choose the font you like if it is the same as the lenguage you want to write)

after that i setup the keyboard on the system by doing:

configuration>keyboard>add keyboard>others>[search Japanese]>add

you add the keyboard and once you do it you´ll just need to click on the key right below to the [ESC] key, it should change the characters displayed to Hiragana or Romanji depending on what font you want to use, have luck and i hope this helped even a bit!

Note: The Kana/Romanji change key works for my keyboard distribution, it could change for yours depending on your keyboard distribution

next ahead some specs and system info for you to have a idea on what i run this settings!

My PC Specs
  • WM: X11

  • DE: GNOME 45.0

  • Core Version: Linux 6.5.7-arch1-1

  • PC model: Acer Aspire ES1-512

  • CPU: Intel® Celeron® N2840 × 2

  • Graphics: Intel® HD Graphics (BYT)

  • RAM: 8.0 GiB

  • ROM: 320.1 GB

Atte: LillyDev さよなら [goodbye]

[Post is made by a newbie user, i found out this by casuality and i needed to share it after seeing the issue on the forums, i hope it helps other users! love you all and have luck on your Endeavour! ]



1 Like

どういたしまして、素晴らしい一日になりますように![you´re welcome, i hope you a great day!]
i am happy it helped you!

1 Like

Thank you!
Wish you the same!

1 Like