How to troubleshoot Outlook website not loading

When I try to load www.hotmail.com in Firefox in endeavourOS, the website get stuck after clicking ‘Sign in’ or after logging in. It keeps on loading until I close it after 5 or more minutes.
The problem exists since about a month. Other websites work okay.

When I try to load Outlook.com on another PC, I have no problems.

Things I have tried to troubleshoot the problem

  • Tried loading with other browsers (Chromium, Qutebrowser); No result. Because of this I suspect the problem may be OS-related and posted in the EndeavourOS forum.
  • Removing Microsoft cookies and emptying Firefox cache
  • Turn off VPN
  • Turn of adblock (Adblock Plus and Privacy Badger)
  • Turn off UFW firewall
  • Disable Pihole.
    All without results, the site keeps getting stuck.
    Googling about troubleshooting Outlook gives only results about servers.

Does anybody have tips to troubleshoot my laptop loading outlook? Is there a (CLI) tool that can show where the Firefox get stuck loading Oulook?

If you open the Web Developer Tools you can monitor the browser’s network connections and see which resources are loading, which are not, and if there are any error messages being returned.

1 Like

I have no issues with outlook page use on Firefox. I do use ublock as installed with no modifications. Nothing else. Some issue you probably have. My settings are also on strict in Firefox.

Edit: If the page that is trying to load is this one then that one is a problem as it takes forever to load.

This one loads instantly

Works fine here using Vivaldi. What happens if you try https://outlook.live.com/owa/ (this is where your link redirects to)?

I signed into Outlook web and Microsoft Education this morning in latest firefox. But I know MS gives me trouble using MS Teams on Firefox.

That being said can you run the following command from terminal

inxi -b

This is so we know your os configuration.

This is what my login looks like after I complete (Gnome Desktop with latest firefox):

@DrDeleto where in the world are you? Works fine here - UK.

Gnome Web (Technology Preview) alpha.43 logs in.

Btw, @DrDeleto welcome to the :enos: forum. I am sure you will love :enos_flag: when you have OWA opening.

Wow! Thank you all for all those replies in such a short time.
@ Ricklinux: Both links you gave load quickly at my browser as well, but the loading is slow when I click ’ sign in’. Maybe its placebo effect, but the first link loads a little less slow :slight_smile:

@ Ajgringo619: I tried Vivaldi, unfortunately the same problem. When I try your link, Is get stuck after clicking ’ sign in on the webpage.

@xircon: I am from the Netherlands.

@kagetora13: My inxi -b is at the bottom of this post.

@HMS_Endeavour: No worries. I use Endeavour for afbout 6 months on end after a period of distrohopping. I love it just the same :wink:

@jonathon: Using the Web Developer Tools I found that Privacy Badger blocked l.clarity.ms, despite being disabled. Removing Privacy badger did not help and the problem is also on other browsers (without Privacy Badger). I have to experiment some more.

System:
  Host: xxxxxxxxxx Kernel: 5.18.11-zen1-1-zen arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.25.3 Distro: EndeavourOS
Machine:
  Type: Laptop System: LENOVO product: 20UD0013MH v: ThinkPad T14 Gen 1
    serial: <superuser required>
  Mobo: LENOVO model: 20UD0013MH v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R1BET68W(1.37 )
    date: 12/23/2021
Battery:
  ID-1: BAT0 charge: 49.0 Wh (95.1%) condition: 51.5/50.5 Wh (101.9%)
CPU:
  Info: 8-core AMD Ryzen 7 PRO 4750U with Radeon Graphics [MT MCP]
    speed (MHz): avg: 1559 min/max: 1400/1700
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa gpu: amdgpu resolution: 1920x1080
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.11-zen1-1-zen)
    v: 4.6 Mesa 22.1.3
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: N/A
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: N/A
Drives:
  Local Storage: total: 476.94 GiB used: 274.54 GiB (57.6%)
Info:
  Processes: 324 Uptime: 12h 29m Memory: 14.86 GiB used: 6.22 GiB (41.8%)
  Shell: Bash inxi: 3.3.19

Hi,

So first thing, I believe you mentioned that this laptop is dual booted? Maybe with Windows? If yes, I would like you to run the Lenovo Vantage utility and update your bios to the latest version which i believe is v1.41. There maybe other firmware updates for devices on your laptop, please do these as well.

Mobo: LENOVO model: 20UD0013MH v: SDK0J40697 WIN
serial: UEFI: LENOVO v: R1BET68W(1.37 )
date: 12/23/2021

Have you always used KDE desktop between your switches between different flavors?

And what Linux Distribution and desktop did you use prior to Endeavour OS?

You could try uMatrix. If you need more granular control then this could be the way to go. Just create rules to your heart’s content.

Hi,

No, my Thinkpad is not double boot. I removed the Windows partitions. However, I can update the firmware with Fwupd. I will try this.
I did not always use KDE, but have also used Cinnamon, Bspwm.
Distro’s I used before Endeavour are Arch, Manjaro, Xubuntu.

So with Manjaro, did you use KDE desktop?

Additionally, have you tried using troubleshooting mode in Firefox (Help > Troubleshoot Mode)? This should should get firefox down to vanilla settings.

With Manjaro I used Cinnamom, not KDE.
I tried the Firefox troubelshoot mode, thanks for the tip. It did not help though.

It has nothing to do with KDE and or Firefox. I use both and i can log into the outlook page with no issues.

1 Like