How to transparent terminal windows on i3-wm?

Ok guys,

So I’ve been building an EPIC setup using i3-gaps. I wanted the cool transparent terminal that people use when they want to look cool. I’ve been looking around for tutorials, but I can’t seem to enable transparency on the whole window itself. What I mean is, I cannot get the whole window to reveal the background on my desktop, but I CAN put a picture within most terminals can make the terminal background color transparent within the window. I find this behavior very peculiar.

Originally, I was going to use Marco for transparency; however I couldn’t find anyone that used Marco, so I went for the Compton meme. After that, paragraph above happened and I am a bit stuck. Any help regarding this matter would be appreciated. Marco preferred.

You can either use picom for transparency or enable transparency from the terminal emulator config if it supports.

Note that if you use picom for transparency, then the text in terminal also becomes transparent. You’ll need to enable blur in picom to help you read text.

I use alacritty teminal emulator, which has inbuilt transparency settings which only makes the background transparent but not the text. This lets me avoid sacrificing on readability. Blur is done using picom.

Add this to ~/.config/picom.conf to enable opacity. (or modify these settings)

inactive-opacity = 0.80;
active-opacity = 0.80;
frame-opacity = 0.80;

Change the values as per your liking.

For blur, add this to the same file

blur: {
  method = "kawase";
  strength = 9;
  background = false;
  background-frame = false;
  background-fixed = false;
}

I don’t know if the community/picom package has blur support. I use aur/picom-ibhagwan-git. Also, you may want to change the blur method to “dual_kawase”. Just see which one works on your system. Kawase doesn’t work on my PC, but works on laptop.

A screenshot of my setup

Edit: whichever way you choose to enable transparency, you need to run a compositor otherwise you’ll get black frames/backgrounds.

2 Likes
exec --no-startup-id picom -CGb

inside i3/config to start it

2 Likes

I’m surprised at how easy that was, thank you.

1 Like