How to switch from Hardened to Zen Kernel?

I understand it has to do with the Grub settings. I followed the instructions as listed in this vod to the letter and am currently in Hardened Kernal but cannot seem to use the same instructions to switch over to the Zen Kernel type.

I’m sure it’s a separate option on the GRUB interface within terminal unless there another way to switch it on bootup. Any advice is greatly appreciated.

Once you install the Zen kernel it should just show up in grub, can you show us your grub menu?

Make sure your system is fully updated:

sudo pacman -Syu

Then install the kernel plus its headers:

sudo pacman -S linux-zen linux-zen-headers

Next, regenerate your Grub configuration:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot and choose the kernel you want to boot form the Grub’s boot menu.


Assuming you have grub set to menu/timeout and have enough of a chance to actually make a selection (I use a zero timeout and saved=true for instance).

Otherwise - ^ that should do it.

1 Like

I’ll give it a whirl. I’m guessing I need to reactivate the sub-menu in this case so I can actually select which kernel I’ll boot into then? Let’s see.

So…after following advised steps no luck. The sub menu from which I could select between different kernels isn’t popping up. Here’s my GRUB settings.

# GRUB boot loader configuration




GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 nowatchdog nvme_load=YES"


# Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices


# Set to 'countdown' or 'hidden' to change timeout behavior,

# press ESC key to display menu.


# Uncomment to use basic console


# Uncomment to disable graphical terminal


# The resolution used on graphical terminal

# note that you can use only modes which your graphic card supports via VBE

# you can see them in real GRUB with the command `vbeinfo'


# Uncomment to allow the kernel use the same resolution used by grub


# Uncomment if you want GRUB to pass to the Linux kernel the old parameter

# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"


# Uncomment to disable generation of recovery mode menu entries


# Uncomment and set to the desired menu colors. Used by normal and wallpaper

# modes only. Entries specified as foreground/background.



# Uncomment one of them for the gfx desired, a image background or a gfxtheme




# Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires

# setting 'GRUB_DEFAULT=saved' above.


# Uncomment to disable submenus in boot menu


# Probing for other operating systems is disabled for security reasons. Read

# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this

# functionality install os-prober and uncomment to detect and include other

# operating systems.


Also, this is a dual boot system with two SSD’s one of which is running Win10 and One which is running EndevourOS of course. Is it possible that’s affecting my ability to switch kernels when starting up EndevourOS? If you see something amiss in my settings please let me know in any case.

Post your /etc/default/grub as text and add ``` above and below it.

Do not post screenshots of text, nobody wants to waste time reading your screenshots and thus the chances of your problem being solved are significantly decreased.

Also, every time you change that file, make sure to apply the changes with:

sudo grub-mkconfig -o /boot/grub/grub.cfg

If you make a mistake, your system may become unbootable, and then you’ll have to boot a live ISO image, chroot and fix the mistake from there. So, to save yourself the trouble of doing so, don’t make a mistake :slight_smile:


Thanks for the heads up. Worst comes to worst I have time shift set up. This is my first time using EndevourOS so I’m just hoping to learn what I can atm.

Just be careful anyway. If you break grub you lost the ability to boot to those timeshift snapshots, so you’re back to the USB stick to get your system back.

1 Like

disable submenu=n will show the submenu. It is mere logic!

So only thing you need is to remove the # in front of that line (i.e. un-commenting that line so it will be read in the future) and update grub afterwards.

1 Like


Welp that was pretty obvious. Thanks for the help though I got it working. I’m now running the mutli-kernel boot options. Out of curiosity why would someone remove that boot menu? Unless, I guess they’re only using one kernel at all times?

Another possibility, if the computer was a company computer, the IT guys might want to eliminate some curious employees from messing around.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.