How to "submit a full bug report" for AUR install issue?

Hey all, I’m not sure if this is a “Applications” issue or an “EndeavourOS Repo” issue, or some other issue, and it’s my first post here…so, “Newbie” category? Quick thanks to the community here, I’ve foraged this forum many times already in my half-year’ish using EndeavourOS, thank you.

My issue, yay updates for about a week have indicated a problem with updating lib32-sane. I’ve noticed yay update issues often ‘get fixed’ on their own so I didn’t pay it much attention. Today I looked and I see it appears to be throwing a compiler error and asking me to please submit a bug report:

Please submit a full bug report, with preprocessed source (by using -freport-bug).
Please include the complete backtrace with any bug report.
See <https://bugs.archlinux.org/> for instructions.

I tried. That URL redirects to a new Github page ( https://gitlab.archlinux.org/archlinux/packaging/packages ) which has a message about “temporarily disable account registrations” due to spam and doesn’t readily appear to lead to those mentioned “instructions”. So I’m at a loss about what to do.

I tried uninstalling the old version of lib32-sane to reinstall, same issue (now with 100% less lib32-sane installed, of course).

Reading the forum info, I noted the requests for hardware info, so in case it’s relevant to this issue:
https://0x0.st/Xow-.txt

Thanks for reading this far, any thoughts, ideas, questions, or recommendations?

Dave

welcome at this purpelized zone :enos:

2 Likes

https://aur.archlinux.org/packages/lib32-sane

If the issue is with this AUR build instructions, you will not need (and should not do) a BUG report at Archlinux Gitlab.

AUR build instructions are maintained and added by users and not official Packages in any way.
Issues with them should be reported at the AUR page in case it is related to the build itself, and issues with the sources yea… at the source of it.

And indeed i bet we can, may help here too to resolve the issue if it is may not anything related to any of the two…

For this, we would need the full error output you got flashed with while the update.

Sweet and thanks, Der Doktor. I’ve definitely read through plenty of your messages in my ‘Endeavour’ thus far!

The full install output is longer than my Konsole buffer, yet you said “full error output”. I think this is the full error output:

during RTL pass: pro_and_epilogue
genesys/gl124.cpp: In member function 'calculate_scan_session':
genesys/gl124.cpp:790:1: internal compiler error: in find_oldest_value_reg, at regcprop.cc:460
  790 | }
      | ^
0x1851644 internal_error(char const*, ...)
        ???:0
0x67856f fancy_abort(char const*, int, char const*)
        ???:0
0xb12eb9 copyprop_hardreg_forward_bb_without_debug_insn(basic_block_def*)
        ???:0
0xb72070 try_shrink_wrapping(edge_def**, rtx_insn*)
        ???:0
0x8859bf thread_prologue_and_epilogue_insns()
        ???:0
Please submit a full bug report, with preprocessed source (by using -freport-bug).
Please include the complete backtrace with any bug report.
See <https://bugs.archlinux.org/> for instructions.
make[4]: *** [/tmp/ccdhckvy.mk:20: /tmp/ccsmt4bL.ltrans6.ltrans.o] Error 1
make[4]: *** Waiting for unfinished jobs....
lto-wrapper: fatal error: make returned 2 exit status
compilation terminated.
/usr/bin/ld: error: lto-wrapper failed
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:4852: libsane-genesys.la] Error 1
make[3]: Leaving directory '/home/dave/.cache/yay/lib32-sane/src/backends-1.3.0/backend'
make[2]: *** [Makefile:4304: all] Error 2
make[2]: Leaving directory '/home/dave/.cache/yay/lib32-sane/src/backends-1.3.0/backend'
make[1]: *** [Makefile:609: all-recursive] Error 1
make[1]: Leaving directory '/home/dave/.cache/yay/lib32-sane/src/backends-1.3.0'
make: *** [Makefile:499: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: lib32-sane-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
lib32-sane - exit status 4

That provide any clues you recognize?

can i ask what for you need lib32-sane?
There are some insane dependencies to build with it…

And no there is no issue with the PKGBUILD i can build install it without issue here.

I’m not positive of my memory, however, I’m pretty sure I installed it to try and solve a compatibility issue with a program under Crossover. I also have an older HP multi-function printer and vaguely recall dealing with some compatibility issues when I first installed EndeavourOS.

Hearing it builds just fine under your system suggests I’ve messed up something in mine. :frowning:

[edited to add HP mention]

but due to the 9 AUR builds for the needed other 32bit libs it could totally be you have done a false selection ion the process… personal i would omit to hell to use such a workaround.

You do run the HP printer over crossover?

I don’t run the scanning parts of the HP under crossover, and at this point it has been months since I’ve needed to print via crossover as well. I’ve been slowly reducing my dependency on it since switching to Linux full time.

Maybe I should try leaving lib32-sane uninstalled (and maybe uninstall it’s dependencies?) and just watch to see if anything fails to work? I’m thinking that may be a more reasonable solution at this point vs. troubleshooting what seems to be a 1-off bug or user error.

We could go to see if we can get the printer working without these 32bit libs. Also crossover should not need them.

I’m good to give that a try. Do you have thoughts for a general gameplan? Uninstall the 32bit libraries, test the printer, if it doesn’t work w/o them, determine what is needed then?

yes go uninstall the libst will need -Rsc i bet but be careful … it can remove needed stuff in circumstances… if unsure show the output before hitting yes !

sudo pacman -Rsc lib32-sane

after this, check if cups (print server/framework) is running:

systemctl status cups

For following procedure, i need the exact model of the printer.

Possibly good new/bad news. Bad news: I can’t uninstall lib32-sane & its dependencies because I already uninstalled it prior to my OP. Good news: digging around a bit with pactree I’ve found a whole bunch more lib32 packages that all appear to have no reverse dependency (e.g. lib32-x265, lib32-pipewire-jack). There’s a decent chance I installed a whole pile of lib32 packages back when I was troubleshooting a program compatibility under crossover.

So I figured I’d ask before doing potential further harm. Do you see any issue with me manually going through all the lib32 packages on my system and removing them if “pactree -r” shows no reverse dependency?

And just a good time to throw in there, thanks for your help thus far!

Removing lib32-* packages should not break your system since your system doesn’t need 32-bit libraries to run. It is possible that some other 32-bit application might not work anymore but you could always reinstall just the packages it needs.

2 Likes