How to stop udisks from triggering a partition?

I installed EOS on a device with a single SSD. I gave this drive 5 partitions. I want 4 of those 5 to be mounted on boot and the fifth to be NOT mounted on boot, only on demand (when accessed).

My fstab currently looks like this:

UUID=57CD-E1F6                            /boot/efi      vfat    defaults,noatime 0 2
UUID=de20c5f1-effc-4b97-b198-c216a0bd0b81 /              ext4    defaults,noatime 0 1
/dev/disk/by-uuid/ecebafd9-2894-4fb8-951b-e0df069b804f /mnt/ecebafd9-2894-4fb8-951b-e0df069b804f ext4 nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Data 0 0
/dev/disk/by-uuid/3f74b8b4-bd2f-4439-acfd-064e6dd7a158 /mnt/3f74b8b4-bd2f-4439-acfd-064e6dd7a158 ext4 nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Backup 0 0
/dev/disk/by-uuid/4316a32d-bec2-43eb-bb88-548dbad72f88 /mnt/4316a32d-bec2-43eb-bb88-548dbad72f88 ext4 nosuid,nodev,nofail,x-gvfs-show,noauto,x-gvfs-name=Storage 0 0

The problem is that after booting, as soon as the desktop appears, udisks is triggering the partition I don’t want to be mounted and I get a password prompt:

How can I avoid this?

One might think that noauto option should have produced the desired effect.

How about commenting out the entry in /etc/fstab, reboot and see if it still triggers auto-mounting.

I guess then you could mount and unmount the device on-demand from the left panel of your file manager.

1 Like

Will try, thx!

1 Like

…and it actually does what’s supposed to do.
With fstab/systemd.mount we configure how the system behaves.
The action that triggers the late mounting is coming from the DE (KDE setting, or applet) for “Auto mount disks”. This is also assumed from the password question, which seems to try to mount to standard user mount points, usually in /run/user/ . (although it should not do that, because of fstab line, but… who knows?.. :person_shrugging: Maybe the /dev/disk/by-uuid is to blame…)
OP should find this setting and modify it to not auto mount.
To verify fstab line is working as intended, try mounting in terminal, without specifying a mount point, or try with a different FM than Dolphin.

4 Likes

@pebcak Commenting out the fstab entry didn’t help.

@petsam Found the file but have no idea how to modify it. Opening with Kate doesn’t work, renaming the file didn’t do anything.

OK, I think I found it:

Seems to work since I changed this setting :slightly_smiling_face:

edit: I will mark the post from @petsam as solution 'cause it pointed in the right direction.

Thx everybody for helping!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.