How to stop cups from browsing & adding printers

In my Gnome Desktop Environment, I manually installed drivers for my Brother printer and set it up with a web browser at localhost:631.
That works very well.

However, cups keeps browsing my network printers and then adds the same printer with options that do not work. If I use the added printer setup by mistake it starts printing just a few letters per page and spits out pages until the printer is turned off. I am tired of wasting paper. Here are the two printers


The top one is my manual setup and it works. It is only identifiable by Location Printer Room
The bottom one is automatically setup by cups and it does not work. If I delete the bottom printer setup, literally 60 seconds later it comes back.

Here is what I have tried, which articles on the subject say this is the solution…NOT.
as root, edit /etc/cups/cups-browsed.conf – and set the following
BrowseRemoteProtocols none
BrowseLocalProtocols none
BrowseProtocols none
BrowseDeny All
reboot computer
That does not work and I am at my wits end. Any help will be appreciated.

Pudge

1 Like

Could this be system-config-printer ?
have no option like this…
but could be this service:

cups-browsed