How to start pgAdmin4 without Postgres?

I am tying to install PgAdmin to connect to a remote Postgres server, which means that the computer has no Postgres. I installed pgadmin4 from the official repository, but when I ran it, it got stuck at the loading screen. I could see the tray icon, but the menu items were all disabled, so that was nothing I could do.

How can I start it? I don’t have to install a Postgres server just to use this app, do I?


not a solution but a workaround.
I really liked pgAdmin3, but I never got 4 running and also some colleagues have problems with it.
We switched to using DBeaver

So, you and all your colleagues have failed to run pgAdmin4 on Arch-based? What if I install a Postgres server on the same PC. It still doesn’t solve the problem?

PgAdmin4 simply is a pain to configure. We didn’t try on Arch based - I don’t see the relevance of that as every linux distribution is basically the same. Having postgres installed on the same system didn’t make any difference in trying to get PgA4 to connect to a remote database.

DBeaver is easy to set up and has the same functionality that we were used from PgAdmin3. Thats why it was an easy decision to go that way. Configuring and connecting to any remote database is done in seconds.

Hmm. When I was using Windows, it just worked. It’s basically just a web app that interfaces a remote DB, which means it shouldn’t have a lot of thing to do with the system’s details. I don’t understand why the developers of PG don’t fix the problem on Linux.

They don’t provide any Flatpak or Snap, but they provide Docker image, so I guess I will try that.

I got the web version (but the desktop version is basically a web version running inside of a native window border, so it’s basically the same thing, in my opinion) working using the Docker method. It was not very difficult, but it required some time.

If anyone else find this thread in the future after searching for a way to get PgAdmin working, I recommend using the Docker method instead of the native package.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.