How to setup Navidrome?

I banged out a few hours trying to get it functioning, changing the .toml variables stop/start service etc. Addendum: in testing via Konsole, it does not seem to be reading the. toml file?
I tried my IP4 IP, pretty much every IP on my network. I am obviously missing something, but what?
I did notice I have a dynamic IP, but I’ve locked myself out of the modem when I changed the password so I need to reset.

I reviewed their (Navidrome.org) documentation for Community, and Linux. I installed from AUR https://aur.archlinux.org/packages/navidrome/

EDIT: I kind of answered my own question when I approached with fresh eyes. I figured out how to change directory for music, but still unsure which IP it needs to broadcast. Please still feel free to comment/suggest if you have Navidrome experience.

Have you tried binding the address to your actual localhost address rather than 0.0.0.0? If you’re setting it up on a server I’d recommend the docker image which was very simple to set up. You may also find better support through their Discord server.

Thanks for the response. Yes, I get the argument it’s already bound:

I’ve ready online some ISP’s won’t allow loopback? My first foray into networking, seemed an interesting way to start.

Someone else is free to correct me but I believe Navidrome runs on your machine’s local IP, which is not 127.0.0.1, but will look something like 192.168.1.x and port 4533. I’m not sure if it’s possible to retrieve your address via the terminal, but if you can access your router, which tends to be at 192.168.1.1 you should be able to see the local IP of your Navidrome server. For example, I can access Navidrome at 192.168.1.254:4533.

Disclaimer: I have no real understanding of networking, and the above speculation is purely based on personal experience.

1 Like

I got somewhere, not sure how, I need to figure that out. I can see my music now. But I still cannot get it to load navidrome.toml but I can execute via Terminal pointing to music directory and it works.

I saw in Sys Mon quite a few instances of navidrome, that is why I was getting the in use error. Thanks for your feedback, it helped to spur me on to dig further. I’m learning, so that’s never a bad thing.

Have you placed your configuration file in the directory which Navidrome is running from? Alternatively you can use --configfile to point it to your .toml document. More info on this can be found here.

1 Like

tried that earlier, told me file type was not recognized. I will keep plugging away to find a solution. Half way there at least.

Obviously it should recognize it, and odds are there’s something else wrong, but for what it’s worth Navidrome also supports loading configurations from .json, yml, and .ini files.

If you can’t make it work, your best bet is the Discord server linked above. Good luck!

1 Like

Thanks for your efforts and feedback @Celty most helpful.

I have it working:

  • Install from aur
  • Create a directory /var/lib/navidrome/music
  • Create a toml as per:
cd /var/lib/navidrome && micro navidrome.toml
#My contents:
MusicFolder = " /data/media/Music/"
#Then
sudo systemctl enable --now navidrome 

Open http://localhost:4355 in your browser and create a user.

One thing, I downloaded an android app - ultrasonic - put your address in with a http:// prefix.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.