How to set wlan0 mode back to DEFAULT instead of DORMANT

Hi guys!

I recently encountered a problem with random wifi death of slow connection. I checked wlan0 status via ip link and discovered that it’s mode set to DORMANT. I tried changing it back by “ip link set wlan0 mode default” and it worked. But after reboot system managed to get wlan0 back to DORMANT.

How do I permanently set wlan0 mode to DEFAULT?

ip link:
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000

P.S my wifi module is RTL8822CE

am I shadow banned or smth? Damn it’s second post where I got no answers or even advice :frowning:

Due to Easter holidays, the Forum’s helpdesk is staffed with unpaid, under-skilled, volunteers.

We are deeply sorry that we have not been able to provide you with the exact solution to your problem right away when a demand has been presented to us.

We beg you hereby to have patience and not create new topics or bump an already existent one since it may lead, not to a ban or shadow ban, but to dismay of the unpaid volunteers dedicating thier free time to help out members of the community.

Happy Holidays!


Damn, I’m sorry…

I didn’t knew you guys has easter holidays. I just don’t have those in Russia, so I didn’t know about it.

P.S. I think I had these holidays much earlier

1 Like

is this something you can fix in systemd I wonder (as far as fixing something’s perpetual state, I mean)?

It’s Sunday and Easter and like most community Linux distros EndeavourOS is being ‘supported’ by volunteers, so it’s not nice to demand answers in an hour. Especially if your request is missing basic informations. Anyway…

Read this:

Post the first two command’s output. I suspect it might be some power saving feature of this wifi adapter.

Did you try googling the error and your hardware? Found a few relevant threads. Like this one, it’s recent.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.