[How to] Scanner HP DeskJet 2632

I installed naps2 package OK, but naps2 cannot find my HP DeskJet 2632 printer/scanner - IMHO - due to lack of drivers naps2 does cannot establish connection to my printer/scanner. Maybe this is not correct conclusion, or ?

In AUR I found hplip-lite (version 3.23.5-1) package. I tried command yay hplip-lite and the package info says is only printer drivers.

This command only downloaded PKGBUILD but building/installation failed. The downloaded package is now in /home/user1/.cache/yay/hplip-lite/PKGBUILD directory and consists of 3 parts: PKGBUILD, .git and .SRCINFO.

My Terminal says:

[user1@hpcomp ~]$ yay hplip-lite
1 aur/hplip-lite 3.23.5-1 (+1 0.05)
Only Print drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
AUR Explicit (1): hplip-lite-3.23.5-1
:: PKGBUILD up to date, skipping download: hplip-lite
1 hplip-lite (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 1
:: Deleting (1/1): /home/user1/.cache/yay/hplip-lite
HEAD is now at 33188ae update 3.23.5
1 hplip-lite (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 1
diff --git /home/user1/.cache/yay/hplip-lite/PKGBUILD /home/user1/.cache/yay/hplip-lite/PKGBUILD
new file mode 100644
index 0000000…7eb16fc
— /dev/null
+++ /home/user1/.cache/yay/hplip-lite/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: yuhldr yuhldr@gmail.com
+pkgdesc=“Only Print drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet”
+license=(‘GPL2’ ‘custom’)
+depends=(libjpeg-turbo libcups)
+makedepends=(python libusb)
+optdepends=(‘cups: for printing support’ ‘system-config-printer’)
+prepare() {

  • cd “${_pkgname}-${pkgver}”
  • rm -rf ./PPD_HP

+build() {

  • cd “${_pkgname}-${pkgver}”
  • ./configure --prefix=/usr \
  • –enable-lite-build \
  • –disable-doc-build \
  • –disable-fax-build \
  • –disable-network-build \
  • –disable-imageProcessor-build \
  • –disable-scan-build
  • make -j $(($(nproc) - 1))

+package() {

  • cd “${_pkgname}-${pkgver}”
  • make DESTDIR=“${pkgdir}/” install
  • install -Dt “${pkgdir}/usr/share/licenses/${pkgname}” -m644 COPYING

After receiving this same result repeatedly I closed Terminal. The downloaded PKGBUILD package remains in the same place as before. Therefore I cannot say if this driver hplip-lite package is the correct one and / or can it fulfill the job of establishing connection from naps2 to to printer/scanner.

How should I proceed ?

Are you using a helper? You may need to press Q to exit the PKGBUILD and proceed with the installation.

@BluishHumility Thank you very much for instruction ! It helped and now hplip-lite is installed. But when I try to scan a document, naps2 informs that it cannot find scanner (i.e. HP DeskJet 2632) with profiles I’ve made into naps2.

In naps 2 I’ve made 2 profiles for this scanner: ‘‘HP DeskJet 2632’’ and ‘‘eSCL HP DeskJet 2600 series [CC0597] (USB)’’ - the first one works OK in Windows 10 and the second one works OK in Fedora 38 and Ubuntu 23.04.

Are there any other Document Scanner applications besides naps2 available for EnOS ?

HP scanners do not work ‘out of the box’, you need a scanner driver. naps2 won’t help you without the driver. The correct conclusion is to install hplip, which is responsible for adding the scanner driver to your system.

Rip out the hplip-lite from the AUR and install hplip. Afterwards, run hp-setup to install printer and scanner driver. If it doesn’t work on first try, use hp-plugin to install or reinstall only the scanner driver plugin.

After doing this, your scanner should work with scanner applications like naps2 and also others like skanlite from KDE or just SANE.

@emk2203 Thank you very much for advises. As a result:

  • ‘hplit-lite’ package was replaced by ‘hplit’ package and
  • after that I’ve run command ‘hp-setup’

now the this HP printer/scanner are connected to EnOS and work OK. :grinning: :grinning: :grinning:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.