How to rice BSPWM with these awesome dotfiles

Can a PRO help to make any of these rices work in EndeavourOS ?
Its not as simple as copy pasting to to .config, I think thats due to missing dependancies or some configs were too compilcated to use (like archcraft bspwmrc)

What changes do we need to do to make it compatible with EndeavourOS BSPWM edition.

1 Like

Not a PRO Not a PRO Not a PRO

Νever is and always was :wink:

Basic rules:

  • Keep backups of EVERY file you change.

  • Read the readMe even if you don’t understand what it says. Look up what each program does. Do you have it? Do you need it? Do you want to learn how to setup/use it? Can you revert the changes?

  • Start small. (maybe from the 1st link) (or not, but you need to search and find out how to make eww widgets work on your system or on your screen resolution (2nd,3rd link) or adapt/replace scripts configured for another distribution on your own (4th link)).

Basic components of a rice:

  • Wallpaper, theme, icons, colors, fonts, bar, some cli programs from ancient times and a fetch script :stuck_out_tongue:

Forget the ( it needs a lot of changes anyway) if you want to know what you’re doing and be able to do it again with any config you like.

Apply wallpaper, theme etc.
Install the fonts you need (or copy them in your ~/.local/fonts and then “fc-cache -f -v”).
Find the settings/configs/colors for the terminal you are using and replace yours (backup first).
(For the 1st link) Find the polybar scripts, find the lines that are specific to void linux, comment them and uncomment the ones that are specific to arch. (I am not a witch, I read the readMe :stuck_out_tongue: )

Try your changes, read the terminal output, correct the errors, try again.

Have fun (don’t listen to me, it’s a rabbit hole. RUN)


I downloaded eww and copied rxyhxn’s eww config file. But how do I run it now? Like when I run ./eww windows, nothing shows up. What do I doooo?

First of all, welcome to the community. :rocketa_purple: I hope you’ll enjoy the journey.

You’ve should created a new topic, maybe a moderator can split this.

Please describe what you did exactly, download is not the same than install a package. Read eww documentation and rxyhn setup instructions, because it seems that’s not enough to copy config file (or folder?) to make it work, you need to check that all dependencies are installed.