How to reset tint2 to its defaults

Good Day!

Guys, how can I restore tint2 to default, which I find after an Openbox Community install?

Load the panel that was default > tint2 settings > theme > reset

1 Like

It is not working, it seems that I deleted such a panel configuration. Is there a way to fully reset tint2 or to bring its original configuration from Github?

I’d look around here:

Register and download the file, or make a new panel and paste the config you see at github.

1 Like

I ran the sequence of commands from the Github page you gave me, they are:

git clone https://github.com/EndeavourOS-Community-Editions/openbox.git

cd openbox

bash openbox-install.sh

So, I received some error messages:

error: target not found: #eos-skel-ce-openbox #not needed for manual script
error: target not found: xorg-xdpyinfoacpi
error: target not found: ttf-nerd-fonts-symbols

You don’t need to run any commands. The tint2rc file you see there is the original. You can download it and load it in Tint2. Or you can make a new panel, open the file in a text editor, delete all you see and replace it with what you see on github, when you click on the tint2rc file. It is in the .config folder.

Here’s the official tint2 gitlab, where they describe how to configure it. You need to replace what is in your config (use a text editor) with what is in the official default EndeavouirOS Openbox one, which you find on their github.
link:https://gitlab.com/o9000/tint2/blob/master/doc/tint2.md

1 Like

Just to be completely clear :slight_smile:

tell your file manager to show hidden files. Go to /home/yourname/.config/tint2, in your home folder.

Ther you’ll see the file tint2rc. Right-click and open in your text editor. There is your panel configuration. What is in your configuartion is likely messed up, as you want to reset it. Therefore you’ll have to replace all the text you see, with the original text.

This original text you can find on the EOS Openbox github. Go into their .config folder and look for the tint2rc file, and click on it.

This procedure is useful to know, because it is how you configure a lot of stuff in Linux. Good luck!

1 Like

It worked. I renamed tint2rc to tint2rc.BAK, then, I copied the content from …

… to a new file named ‘tint2rc’ (~/.config/tint2/tint2rc).

So, I saved it, logged out and back in.

My tint2 now looks as I found after installing EndeavourOS Community, however, my autostart also reset back to what it was.

Is it expected?

No, your autostart is in your openbox config, which you haven’t touched now.

Likely, your tint2 openbox autostart entry is pointing to a different tint2 config file. Use the same procedure as above, and find the “autostart” file in /.config/openbox. open with a text editor. Look for the tint2 entry, and see if it is pointing to the tint2 file you just edited.

1 Like

Perhaps I misunderstood. What exactly has changed in your autostart?

1 Like

Only thing I can think of, is that when you gitcloned and started that script, some stuff got overwritten.

I should have been a bit clearer about NOT running any commands, just edit your config text files.

1 Like

I added some apps - cherrytree, parcellite, skype, synapse, and plank - to the file ‘~/.config/openbox/autostart’, but the file ‘autostart’ returned to what it was before my changes.

Almost everything returned to an “out of the box” state.

I apologize for so many questions, as well as I thank you, dear LamnaNasus, for all your support. This is the first time I’m running OpenBox, so I’m a bit lost. The good point is that things are working again, thanks to your support.

May the Gods grant you a beautiful week and thank you again! :slight_smile:

1 Like

Hail Odin.

The gitclone and script start could have made a mess. Hopefully it just replaced files with the virgin original ones.

I guess perhaps theoretically you could do an Arch base install, and then gitclone EOS Openbox, and then boot into EOS openbox. perhaps minus some configuration like EOS repos and such. I’ll have to do that experiement some time.

Happy you made it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.