How to Reset the Gnome Keyboard Shortcuts after they were altered by an Extension

Hi

I’ve been testing the Gnome Extension gnome-shell-extension-material-shell and as a result it has alternated many of the default Gnome Keyboard Shortcuts. After I uninstalled the extension I noticed that the keyboard shortcuts did not reset to their defaults (e.g. SUPER 1 to launch the first application in the dock).

Question, Is there a method to reset all of Gnome Keyboard Shortcuts to their defaults?

I have tried going into Gnome Settings > Keyboard > Keyboard Shortcuts > Reset All. This has not fixed the issue described.

Source:

https://help.gnome.org/users/gnome-help/stable/keyboard-shortcuts-set.html.en

First try opening Gnome System Settings, navigate to Keyboard and under the title “Keyboard Shortcuts” click on “Customized Shortcuts” which will open a new dialog box that shows a list of keyboard shortcut types and there should be something like “3 modified” (the numbers can range of course from lower or higher), which will let you know you have altered some of the default shortcuts. Now at the very top of this dialog box there should be a “Reset All” button, click that and it should restore the keys to their defaults. Let me know if that works, if not, we’ll have to give the dconf editor a try, but that requires a little more explanation, so let me know if this first one fixes it or not.

Here’s a screenshot for reference of where to look, notice the “Reset All” button in the top right of the window:

1 Like

Hi Scotty,

Thanks for your feedback. I have tried performing the reset you mentioned “Gnome Settings > Keyboard > Keyboard Shortcuts > Reset All”. After I choose ‘Reset All’ the Gnome Setting screen will just close on its own. I reboot my laptop to see if keys like the <SUPER 1> are fixed, which is still not launching the first application on the dock.

Additionally when I was first researching the issue I also removed the custom shortcuts which I assume came from the extension.

The other option we can try, install dconf-editor, it’s in the official repos:

sudo pacman -S dconf-editor

When you open up dconf editor, you’ll be greeted with a warning just accept it acknowledging you’ll be careful, since this allows you to adjust various system values. It functions similar to the heiarchy how nautilus works, folders within folders, so that’s how we’re going browse to get to the keybindings.

You should see something like this to start off:

Now we want to navigate to the keybindings, so for that follow by clicking the following folders:

org > gnome > desktop > wm > keybindings

In the keybindings window, anything that is in BOLD and has a “pencil icon” next to it means these were values that were altered. If you have any of those, you can click them which will open their settings and near the bottom of that you should see a toggle that says “Use Default value” and toggle that on or off depending on which, if any values are in BOLD with the pencil icon next to it.

Here’s what a few values that I adjusted so they aren’t a default look like:

In this screenshot, I altered the show-desktop value, so it’s bold, if I wanted to return it to the default, I would do what I mentioned in the paragraph directly above to achieve that.

One other thing work checking out real quick, is if you also then go back to the “wm” folder, which you can simply click on “wm” in the headerbar on the top of the window. In this settings window you have keybindings and preferences, click into “preferences”

Be careful what you change here, since depending on what you’ve tweaked with Gnome Tweaks, you may not want to edit any of these values, so simply have a look around to get familiar first. One thing I am curious about in your “preference” folder is the value “mouse-button-modifier” mine is set to ‘’

Now admittedly, I’m not an expert in dconf wizardry, so this value may be entirely irrelevant, but check out the “keybindings” folder like I mentioned above and report back and we’ll try to go from there.

2 Likes

After some further digging around, I think this may be of the best help. Navigate to the keybindings within gnome-shell:

org > gnome > shell > in there are a bunch of subfolders, select keybindings

This will take you to what should look like the screenshot I posted above. Since you mention you had issues with Super+1, etc, this is where the keybindings for that are. In my screenshot I haven’t adjusted those values so what you are looking at are the defaults. I assume yours are altered or off, so you may have to go in and manually reset them to their defaults.

1 Like

Super+1 was set by an extension as well, so resetting to default will wipe. so:

  • List all your extensions
  • Uninstall the ones you think changed shortcuts (e.g. dash-to-dock)
  • Reset shortcuts
  • Reinstall extensions.

Hi Scotty,

Thank for your detailed solution. Your were 100% right that I need to use the ‘dconf editor’ and then navigate to “/org/gnome/shell/keybindings” to then set the values to the defaults. This is what it looked like before:

I then edited each of the switch to application hot keys using the default toggle switch:

From:

To:

I will share this solution in the bug (thank you) and go back to the developer and ask them for a list of all the changes the extension made. I really want to clean my Gnome desktop back to the defaults so I can properly test in the future.

@kagetora13 No worries, happy to help, it gave me a good reason to dust off dconf-editor and learn about a few other settings I had been looking for myself, so it’s a win win. Hopefully the dev is able to assist you with your bug report. Just do be aware dconf-editor is a powerful and handy tool, so don’t adjust things unless you know what you are doing as there’s always a risk to break things. But in this case since we were only adjusting keyboard bindings, the risk was non-existent thankfully.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.